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Foreword
Thank you for purchasing AddTrigger. This user’s manual explains the operating 
procedures of the AddTrigger software. To ensure correct use, please read this manual 
thoroughly before beginning operation. After reading the manual, keep it in a convenient 
location for quick reference whenever a question arises.

Notes
•	 The contents of this manual are subject to change without prior notice as a result of 

continuing improvements to the software’s performance and functions.
•	 Every effort has been made in the preparation of this manual to ensure the accuracy 

of its contents. However, should you have any questions or find any errors, please 
contact your nearest Yokogawa dealer as listed on the back cover of this manual.

•	 Copying or reproducing all or any part of the contents of this manual without 
Yokogawa’s permission is strictly prohibited.

•	 Use of this product (software and this manual) on more than one computer at the 
same time is prohibited. Use by more than one user is also prohibited.

•	 Transfer or lending of this product to any third party is prohibited.
•	 Yokogawa Electric Corporation provides no guarantees other than for physical 

deficiencies found on the original disk or this manual upon opening the product 
package.

•	 Yokogawa Electric Corporation shall not be held responsible by any party for any 
losses or damage, direct or indirect, caused by the use or any unpredictable defect of 
the product.

•	 License numbers will not be reissued. Please keep the serial number in a safe place.

Trademarks
•	 DAQWORX, DAQLOGGER, and DAQEXPLORER are registered trademarks or 

trademarks of Yokogawa Electric Corporation.
•	 Microsoft and Windows are registered trademarks or trademarks of Microsoft 

Corporation in the United States and/or other countries.
•	 Adobe and Acrobat are registered trademarks or trademarks of Adobe Systems 

Incorporated.
•	 Company and product names that appear in this manual are registered trademarks or 

trademarks of their respective holders.
•	 The company and product names used in this manual are not accompanied by the 

registered trademark or trademark symbols (® and ™).

Revisions
•	 1st Edition:		 June 2003
•	 2nd Edition:	 August 2005
•	 3rd Edition:	 June 2007
•	 4th Edition:		 March 2008
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Terms and Conditions of the Software License

NOTICE - PLEASE READ CAREFULLY BEFORE USE
Thank you very much for purchasing this medium containing a software program and related documentation provided by Yokogawa Electric Corporation (hereinafter called 
“Yokogawa”), and the program contained, embedded, inserted or used in the medium (hereinafter called the “Yokogawa Software Program”).

By opening this package or plastic wrapping (hereinafter called “Package”) enclosing  the Yokogawa Software Program, you acknowledge that you understand and agree to 
the “Terms and Conditions of the Software License” (hereinafter called “Terms and Conditions”) which is written in the documentation and separately attached. Accordingly, 
the Terms and Conditions bind you.

The Yokogawa Software Program and its related documentation including ownership of copyright shall remain the exclusive property of Yokogawa or those third parties from 
whom sublicensed software in the Yokogawa Software Program is licensed.

Yokogawa hereby grants you permission to use the Yokogawa Software Program on the conditions that you agree to the Terms and Conditions before you open the Package 
and/or install it in or onto a computer.

IF YOU DO NOT AGREE TO THE TERMS AND CONDITIONS, YOU CANNOT OPEN THE PACKAGE, AND MUST IMMEDIATELY RETURN IT TO YOKOGAWA OR ITS 
DESIGNATED PARTY.

Terms and Conditions of the Software License
Yokogawa Electric Corporation, a Japanese corporation (hereinafter called “Yokogawa”), grants permission to use this Yokogawa Software Program (hereinafter called the 
“Licensed Software”) to the Licensee  on the conditions that the Licensee agrees to the terms and conditions stipulated in Article 1 hereof.
You, as the Licensee (hereinafter called “Licensee”), shall agree to the following terms and conditions for the software license (hereinafter called the “Agreement”) based on 
the use intended for the Licensed Software.
Please note that Yokogawa grants the Licensee permission to use the Licensed Software under the terms and conditions herein and in no event shall Yokogawa intend to 
sell or transfer the Licensed Software to the Licensee.
Licensed Software Name:	 AddTrigger (Model WX13)
Number of License:		  1

Article 1 (Scope Covered by these Terms and Conditions)
1.1	 The terms and conditions stipulated herein shall be applied to any Licensee who purchases the Licensed Software on the condition that the Licensee consents to agree 

to the terms and conditions stipulated herein.
1.2	 The “Licensed Software” herein shall mean and include all applicable programs and documentation, without limitation, all proprietary technology, algorithms, and know-

how such as a factor, invariant or process contained therein.

Article 2 (Grant of License)
2.1	 Yokogawa grants the Licensee, for the purpose of single use, non-exclusive and non-transferable license of the Licensed Software with the license fee separately agreed 

upon by both parties.
2.2	 The Licensee is, unless otherwise agreed in writing by Yokogawa, not entitled to copy, change, sell, distribute, transfer, or sublicense the Licensed Software.
2.3	 The Licensed Software shall not be copied in whole or in part except for keeping one (1) copy for back-up purposes. The Licensee shall secure or supervise the copy 

of the Licensed Software by the Licensee itself with great, strict, and due care.
2.4	 In no event shall the Licensee dump, reverse assemble, reverse compile, or reverse engineer the Licensed Software so that the Licensee may translate the Licensed 

Software into other programs or change it into a man-readable form from the source code of the Licensed Software. Unless otherwise separately agreed by Yokogawa, 
Yokogawa shall not provide the Licensee the source code for the Licensed Software.

2.5	 The Licensed Software and its related documentation shall be the proprietary property or trade secret of Yokogawa or a third party which grants Yokogawa the rights. In no 
event shall the Licensee be transferred, leased, sublicensed, or assigned any rights relating to the Licensed Software.

2.6	 Yokogawa may use or add copy protection in or onto the Licensed Software. In no event shall the Licensee remove or attempt to remove such copy protection.
2.7	 The Licensed Software may include a software program licensed for re-use by a third party (hereinafter called “Third Party Software”, which may include any software 

program from affiliates of Yokogawa made or coded by themselves.)  In the case that Yokogawa is granted permission to sublicense to third parties by any licensors (sub-
licensor) of the Third Party Software pursuant to different terms and conditions than those stipulated in this Agreement, the Licensee shall observe such terms and conditions 
of which Yokogawa notifies the Licensee in writing separately.

2.8	 In no event shall the Licensee modify, remove or delete a copyright notice of Yokogawa and its licenser contained in the Licensed Software, including any copy 
thereof.

Article 3 (Restriction of Specific Use)
3.1	 The Licensed Software shall not be intended specifically to be designed, developed, constructed, manufactured, distributed or maintained for the purpose of the following 

events:
a)	 Operation of any aviation, vessel, or support of those operations from the ground;,
b)	 Operation of nuclear products and/or facilities;,
c)	 Operation of nuclear weapons and/or chemical weapons and/or biological weapons; or
d)	 Operation of medical instrumentation directly utilized for humankind or the human body.

3.2	 Even if the Licensee uses the Licensed Software for the purposes in the preceding Paragraph 3.1, Yokogawa has no liability to or responsibility for any demand or 
damage arising out of the use or operations of the Licensed Software, and the Licensee agrees, on its own responsibility, to solve and settle the claims and damages 
and to defend, indemnify or hold Yokogawa totally harmless, from or against any liabilities, losses, damages and expenses (including fees for recalling the Products and 
reasonable attorney’s fees and court costs), or claims arising out of and related to the above-said claims and damages.

Article 4 (Warranty)
4.1	 The Licensee shall agree that the Licensed Software shall be provided to the Licensee on an “as is” basis when delivered. If defect(s), such as damage to the medium 

of the Licensed Software, attributable to Yokogawa is found, Yokogawa agrees to replace, free of charge, any Licensed Software on condition that the defective 
Licensed Software shall be returned to Yokogawa’s specified authorized service facility within seven (7) days after opening the Package at the Licensee’s expense. As 
the Licensed Software is provided to the Licensee on an “as is” basis when delivered, in no event shall Yokogawa warrant that any information on or in the Licensed 
Software, including without limitation, data on computer programs and program listings, be completely accurate, correct, reliable, or the most updated.

4.2	 Notwithstanding the preceding Paragraph 4.1, when third party software is included in the Licensed Software, the warranty period and terms and conditions that apply 
shall be those established by the provider of the third party software.
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4.3	 When Yokogawa decides in its own judgement that it is necessary, Yokogawa may from time to time provide the Licensee with Revision upgrades and Version upgrades 
separately specified by Yokogawa (hereinafter called “Updates”).

4.4	 Notwithstanding the preceding Paragraph 4.3, in no event shall Yokogawa provide Updates where the Licensee or any third party conducted renovation or improvement 
of the Licensed Software.

4.5	 THE FOREGOING WARRANTIES ARE EXCLUSIVE AND IN LIEU OF ALL OTHER WARRANTIES OF QUALITY AND PERFORMANCE, WRITTEN, ORAL, OR 
IMPLIED, AND ALL OTHER WARRANTIES INCLUDING ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE ARE 
HEREBY DISCLAIMED BY YOKOGAWA AND ALL THIRD PARTIES LICENSING THIRD PARTY SOFTWARE TO YOKOGAWA.

4.6	 Correction of nonconformity in the manner and for the period of time provided above shall be the Licensee’s sole and exclusive remedy for any failure of Yokogawa to 
comply with its obligations and shall constitute fulfillment of all liabilities of Yokogawa and any third party licensing the Third Party Software to Yokogawa (including any 
liability for direct, indirect, special, incidental or consequential damages) whether in warranty, contract, tort (including negligence but excluding willful conduct or gross 
negligence by Yokogawa) or otherwise with respect to or arising out of the use of the Licensed Software.

Article 5 (Infringement)
5.1	 If and when any third party should demand injunction, initiate a law suit, or demand compensation for damages against the Licensee under patent right (including utility 

model right, design patent, and trade mark), copy right, and any other rights relating to any of the Licensed Software, the Licensee shall notify Yokogawa in writing to 
that effect without delay.

5.2	 In the case of the preceding Paragraph 5.1, the Licensee shall assign to Yokogawa all of the rights to defend the Licensee and to negotiate with the claiming party. 
Furthermore, the Licensee shall provide Yokogawa with necessary information or any other assistance for Yokogawa’s defense and negotiation. If and when such a 
claim should be attributable to Yokogawa, subject to the written notice to Yokogawa stated in the preceding Paragraph 5.1, Yokogawa shall defend the Licensee and 
negotiate with the claiming party at Yokogawa’s cost and expense and be responsible for the final settlement or judgment granted to the claiming party in the preceding 
Paragraph 5.1.

5.3	 When any assertion or allegation of the infringement of the third party’s rights defined in Paragraph 5.1 is made, or when at Yokogawa’s judgment there is possibility of 
such assertion or allegation, Yokogawa will, at its own discretion, take any of the following countermeasures at Yokogawa’s cost and expense.
a)	 To acquire the necessary right from a third party which has lawful ownership of the right so that the Licensee will be able to continue to use the Licensed 

Software;
b)	 To replace the Licensed Software with an alternative one which avoids the infringement; or
c)	 To remodel the Licensed Software so that the Licensed Software can avoid the infringement of such third party’s right.

5.4	 If and when Yokogawa fails to take either of the countermeasures as set forth in the preceding subparagraphs of Paragraph 5.3, Yokogawa shall indemnify the Licensee 
only by paying back the price amount of the Licensed Software which Yokogawa has received from the Licensee. THE FOREGOING PARAGRAPHS STATE THE 
ENTIRE LIABILITY OF YOKOGAWA AND ANY THIRD PARTY LICENSING THIRD PARTY SOFTWARE TO YOKOGAWA WITH RESPECT TO INFRINGEMENT OF 
THE INTELLECTUAL PROPERTY RIGHTS INCLUDING BUT NOT LIMITED TO, PATENT AND COPYRIGHT.

Article 6 (Liabilities)
6.1	 If and when the Licensee should incur any damage relating to or arising out of the Licensed Software or service that Yokogawa has provided to the Licensee under 

the conditions herein due to a reason attributable to Yokogawa, Yokogawa shall take actions in accordance with this Agreement. However, in no event shall Yokogawa 
be liable or responsible for any special, incidental, consequential and/or indirect damage, whether in contract, warranty, tort, negligence, strict liability, or otherwise, 
including, without limitation, loss of operational profit or revenue, loss of use of the Licensed Software, or any associated products or equipment, cost of capital, loss 
or cost of interruption of the Licensee’s business, substitute equipment, facilities or services, downtime costs, delays, and loss of business information, or claims of 
customers of Licensee or other third parties for such or other damages. Even if Yokogawa is liable or responsible for the damages attributable to Yokogawa and to the 
extent of this Article 6, Yokogawa’s liability for the Licensee’s damage shall not exceed the price amount of the Licensed Software or service fee which Yokogawa has 
received. Please note that Yokogawa shall be released or discharged from part or all of the liability under this Agreement if the Licensee modifies, remodels, combines 
with other software or products, or causes any deviation from the basic specifications or functional specifications, without Yokogawa’s prior written consent.

6.2	 All causes of action against Yokogawa arising out of or relating to this Agreement or the performance or breach hereof shall expire unless Yokogawa is notified of the 
claim within one (1) year of its occurrence.

6.3	 In no event, regardless of cause, shall Yokogawa assume responsibility for or be liable for penalties or penalty clauses in any contracts between the Licensee and its 
customers.

Article 7 (Limit of Export)
Unless otherwise agreed by Yokogawa, the Licensee shall not directly or indirectly export or transfer the Licensed Software to any countries other than those where Yokogawa 
permits export in advance.

Article 8 (Term)
This Agreement shall become effective on the date when the Licensee receives the Licensed Software and continues in effect unless or until terminated as provided herein, 
or the Licensee ceases using the Licensed Software by itself or with Yokogawa’s thirty (30) days prior written notice to the Licensee.

Article 9 (Injunction for Use)
During the term of this Agreement, Yokogawa may, at its own discretion, demand injunction against the Licensee in case that Yokogawa deems that the Licensed Software is 
used improperly or under severer environments other than those where Yokogawa has first approved, or any other condition which Yokogawa may not permit.

Article 10 (Termination)
Yokogawa, at its sole discretion, may terminate this Agreement without any notice or reminder to the Licensee if the Licensee violates or fails to perform this Agreement. 
However, Articles 5, 6, and 11 shall survive even after the termination.

Article 11 (Jurisdiction)
Any dispute, controversies, or differences between the parties hereto as to interpretation or execution of this Agreement shall be resolved amicably through negotiation 
between the parties upon the basis of mutual trust. Should the parties fail to agree within ninety (90) days after notice from one of the parties to the other, both parties hereby 
irrevocably submit to the exclusive jurisdiction of the Tokyo District Court (main office) in Japan for settlement of the dispute.

Article 12 (Governing Law)
This Agreement shall be governed by and construed in accordance with the laws of Japan. The Licensee expressly agrees to waive absolutely and irrevocably and to the 
fullest extent permissible under applicable law any rights against the laws of Japan which it may have pursuant to the Licensee’s local law.

Article 13 (Severability)
In the event that any provision hereof is declared or found to be illegal by any court or tribunal of competent jurisdiction, such provision shall be null and void with respect to 
the jurisdiction of that court or tribunal and all the remaining provisions hereof shall remain in full force and effect.

Terms and Conditions of the Software License
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How to Use This Manual

Structure of the Manual
This user’s manual consists of the following chapters.

Chapter Title Description
1 Before Using AddTrigger Gives an overview of the AddTrigger software. 

Lists the PC requirements for running AddTrigger, 
the installation procedures, and other information.

2 Entering Settings (Launcher) Gives procedures for entering environment 
settings and conditions on AddTrigger. 

3 Logging Data (Launcher) Lists procedures for logging data. Also gives 
explanations for how to display the data logging 
status and display a list of saved files. 

4 Monitoring Data (Data Monitor) Describes how to display logged data using 
waveforms, numeric values, or meters, and how 
to change the displays. 

5 Displaying Logged Data (Historical Viewer)
 Describes how to display the logged data as 

waveforms or numeric values and how to change 
the displays. Also describes how to compute 
statistics over a specified area of measured data 
and how to convert the data format. 

6 Error Messages and Corrective Actions
Lists error messages and their corrective actions. 

Index

Scope of This Manual
This manual provides instructions on how perform basic operations with the software 
when running under Windows XP, Windows 2000, and Windows. For information 
regarding the basic operations of Windows, see the Windows user’s manual.

Conventions Used in This Manual
Units
K		  Denotes 1024.	 Example: 100 KB
M		  Denotes 1024 K.	 Example: 10 MB
G		  Denotes 1024 M.	 Example: 2 GB

Boldface Type
Hardware and software controls that the user manipulates such as dialog boxes, buttons, 
and menu commands are often set in boldface type.

Subheadings
On pages in chapters 1 through 6 that describe operating procedures, the following 
subheadings are used to distinguish the procedure from their explanations.

			 

Procedure This subsection contains the operating procedure used to carry out
the function described in the current section. All procedures are
written with inexperienced users in mind; experienced users may
not need to carry out all the steps.

			   Note Calls attention to information that is important for proper operation 
of the instrument.
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1.1	 Overview of Functions

AddTrigger is a software program that performs data logging according to user-specified 
conditions.

System Configuration
The following hardware and software are required to use AddTrigger.
•	 A personal computer (PC) running AddTrigger.
•	 A data logging system.
•	 Data logging software (DAQLOGGER, DAQ32Plus, or MXLOGGER).

•	 A PC.
•	 A recorder or similar instrument.

•	 An Ethernet network.

		

AddTriggerData logging 
software

PC PC

Ethernet

Scanned measured data

Scan and record measured 
data from a recorder or a 
similar instrument

Connect the PC on which the data logging software is running and the PC on which 
AddTrigger is running to the Ethernet network. AddTrigger is connected to the data 
logging software via the Ethernet network.
AddTrigger retrieves measured data that the data logging software is logging from a 
recorder or a similar instrument. AddTrigger operates based on the time information 
retrieved from the data logging software.
AddTrigger can only connect to a single PC with data logging software at any given time.

Data Logging Statuses and Terminology
AddTrigger has the following five statuses related to data logging as shown below.

Scan period (scan status)
Record period (record status)

Start scan
Start recording

Start
condition

met

Start
condition

met

End
condition

met

End
condition

met
End recording

End scan

Scanning
period*1

Scanning
period*1

Scanning
period*1

Unconnected

Scanning
status*2

Scanning
status*2

Scanning
status*2

Logging status

Logging
period

Logging status

Logging
period

*1 Scanning period within the recording period
*2 Scanning status when in record status 

Unconnected
AddTrigger is not connected to the data logging software.
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1.1  Overview of Functions

Scan
Scan refers to the act of retrieving the measured data from the data logging software at 
a predetermined interval (scan interval). The scan interval of AddTrigger is the same as 
that specified on the data logging software to which AddTrigger is connected.
Scan starts when AddTrigger is connected to the data logging software. Scan continues 
until the connection is dropped.
The fastest scan intervals are indicated below.
•	 When connected to DAQ32Plus: 0.5 s
•	 When connected to DAQLOGGER: 1 s
•	 When connected to MXLOGGER: 0.01 s
Scan is allowed on a maximum of 1600 channels.

Record
Record refers to the act of logging data according to the logging conditions. Record 
status is divided into scanning status and logging status.

Scanning
Scanning refers to the status in which AddTrigger monitors whether the logging start 
condition is met after recording is started. Logging starts when the logging start condition 
is met.

Logging
Logging refers to the act of saving the measured data to a file on the hard disk at a 
predetermined interval (logging interval). In the logging status, AddTrigger monitors 
whether the logging end condition is met. When the logging condition is met, AddTrigger 
stops recording or enters the scanning status in which the next logging start condition is 
monitored for.
The logging interval can be set equal to the scan interval or its integer multiple.
Logging is allowed on a maximum of 1600 channels.

Logging Function
AddTrigger can start or stop logging of events occurring during data logging based on a 
trigger. The following can be set as trigger conditions: activation/cancellation of alarms 
on a channel (alarm trigger), channel data values (level trigger), at a given time during 
the day (time trigger), or the number of saved data.

		

Measured items

Data
logger

Scanning
(channel time)

Channels
being logged

Start
trigger

Stop
trigger

Start
trigger

Stop
trigger

Time

Logging
start

Logging
stop

Logging
start

Logging
stop

Data saved Data saved
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AddTrigger Structure
The following figure shows the structure of AddTrigger.

Monitor
server

Monitor

Viewer

Display

LoggingScan

Scan interval

Interval (logging)

Display

Redisplay

Data memory
(1800 data)

Logging
status

memory

Launcher

Data
memory

Logger

AddTrigger

HD HDMemory

Software

AddTrigger connects to the monitor server of the data logging software.
•	 Data Monitor is a software program that displays the measured data retrieved from the 

monitor server at the scan interval.
•	 You can display up to 1800 data using the program.
•	 Historical Viewer is a software program for displaying measured data that has been 

saved.
•	 Logger is a software program that logs measured data. Logger runs according to the 

logging conditions that are specified on the Launcher. The program does not appear 
on the screen.

•	 Launcher is a software program that controls the operation of AddTrigger by 
maintaining the logging conditions, connecting to the monitor server, and starting 
various software programs.

Launcher
To use AddTrigger, you must run Launcher. Launcher has the following functions.
Project Management
•	 Project refers to a unit of AddTrigger settings that are grouped by user or purpose. You 

can create multiple projects and save them. For example, if you save the settings for 
logging the data of process A as Project 1, you only need to select Project 1 to recall 
the settings for logging the data of process A.

•	 You can limit user access to projects by assigning passwords to those projects 
(password protection).

Software When Password Protection Is Enabled
Launcher Operations related to data logging are not allowed.
Data Monitor All operations are allowed.
Historical Viewer All operations are allowed.

Note
The information included in a project are the data logging conditions, the monitor server to be 
connected to, and the settings for the Launcher, Overview, Data Monitor, and Historical Viewer.
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1.1  Overview of Functions

Setting Up Logging Conditions
You can enter the connection destination and logging conditions.
The display conditions used when displaying the logged data using Historical Viewer can 
also be specified.
See page 1-6, “Data Logging Conditions.”

Starting and Stopping Scan/Record
You can start or stop the scan. Also, you can set AddTrigger to start the scan when 
Launcher is started.
You can also start or stop recording.
You can set AddTrigger to start recording when Launcher is started.

Starting Data Monitor, Overview, and Historical Viewer
You can start Data Monitor, Overview, and Historical Viewer.

Displaying the Logging Results and Logging Status
The recording status can be displayed.
•	 Recording status display
	 The recording status is displayed using characters and colors. The recording statuses 

consist of Stopped, Scanning, Logging, and Error Stop.
•	 Detailed display of the recording status
	 The details of the recording status are displayed. The information includes the logging 

start time/stop time, the trigger count,* the number of data points written (logging 
count), the name of the logging data file, free space on the save destination hard disk, 
and the status of automatic conversion.
*	 See page 1-6, “Data Logging Conditions.” 

•	 Data file list
	 Lists information about the saved data files. The file number, the (current) trigger 

count, the file name, the time of the first data point, the time of the last data point, and 
the total number of data points are displayed.

Other Functions
•	 You can hide the icons displayed on the desktop and the Windows taskbar so that 

other programs cannot be started (desktop protection).
•	 This function prevents shutting down of your PC when AddTrigger is running. (shutting 

down protection)

For details on Launcher operation, see chapters 2 and 3.

Data Monitor
Data Monitor is started from the Launcher. Data Monitor displays the scanned data on 
the following six types of monitors.
•	 Trend monitor
	 Displays the scanned data using waveforms. You can carry out operations such as 

expanding or reducing the time axis and changing the display zone of each channel.
•	 Numeric monitor
	 Displays the scanned data using numeric values.
•	 Meter monitor
	 Displays the scanned data using a meter. You can select bar meter, analog meter, or 

thermometer.
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•	 Alarm monitor
	 Displays the alarm status of all groups on a single screen (overview display).
	 If an alarm occurs on any one of the channels in a group, the group shows an alarm 

indication.
	 The alarm monitor also displays a log of alarm activations/cancellations for each 

channel including the alarm type, date and time of activation/cancellation, and channel 
name (alarm log display).

•	 Color graph monitor
	 Displays the scanned data by assigning the following 5 colors in order. [1]
	 Blue (minimum display scale), light blue, green, yellow, red (maximum display scale).
•	 Circular monitor
	 Displays the scanned data using a circular graph.

Note
The channels that can be displayed in the monitor are those for which Scan was set to ON in 
the channel settings under Log Settings (see page 2-18).

•	 The displayed data is updated at the scan interval.
•	 You can change the display conditions by carrying out tasks such as changing the 

channels assigned to a group and turning ON/OFF the waveform display. The display 
conditions can also be saved.

Note
The display conditions can be set independently of the display conditions set on Launcher that 
are used when displaying the logged data on Historical Viewer.

See chapter 4 for information on how to operate Data Monitor.

Historical Viewer
Historical Viewer is started using Launcher or the Windows Start menu.
The viewer displays the measured data that has been logged. You can also convert the 
data format before saving.
•	 Historical Viewer can only process data that has been completely logged by 

AddTrigger. For data that are currently being logged, Historical Viewer can handle only 
the section that has been stored to the hard disk. The file name extension is .mld.

•	 You can change the display conditions by carrying out tasks such as changing the 
channels assigned to a group and turning ON/OFF the waveform display. You can 
also save the modified display conditions.

•	 You can connect to files containing divided data (see page 1-6, “Data Logging 
Conditions”) and display the results.

•	 You can calculate the maximum, minimum, P-P, mean, and rms values over the area 
that is specified by the cursor.

•	 Marks can be placed at arbitrary positions on the measured data.
•	 You can set search conditions and search for measured data, alarms, and marks.
•	 You can extract a section of the file to be stored to another file.
•	 The data can be converted to ASCII, Lotus, or Excel format.
•	 You can print the displayed data (separate printer required).

See chapter 5 for information on how to operate Historical Viewer.
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Data Logging Conditions
The data logging conditions are set using Launcher.
Settings are available for logging, channels, groups, comments, and automatic 
conversion.

Logging Settings
You can specify the recording rate, trigger repeat count, logging start/stop conditions, 
data file output destination, data file name, and the trigger confirmation count.

Logging Interval
Set an integer multiple (recording rate) of the scan interval.

		

Logging interval Time when data is saved

Scan Interval Time of the data retrieved from the Monitor Server

Time

Example in which the recording rate is set to 4

Logging Start/Stop Conditions
•	 Alarm (Start/Stop Conditions)
	 You can select an arbitrary number of alarms from an arbitrary number of channels, 

and set the statuses and changes of those alarms to trigger activation conditions. 
Logging starts or stops when the trigger conditions are met. The trigger activation 
conditions that can be set to the selected alarms are AND or OR.

Logging start Logging stop

Logging status Logging status

Record start Record stop

Specified alarm Specified alarm

Trigger point (point when 
the alarm status changes)

Trigger point (point when 
the alarm status changes)

Logging start when set to Alarm Logging stop when set to Alarm

Scanning status Scanning status

•	 Level (Start/Stop Conditions)
	 Select arbitrary channels, and set triggers to activate depending on the relationship 

between those channels specified thresholds and measured values. Logging starts 
or stops when the trigger conditions are met. The trigger conditions between each 
specified channel are all AND or OR.

Trigger point Trigger point

Scanning status Scanning status

Logging start Logging stop

Logging status Logging status

Record start Record stop

Logging start when set to Level Logging stop when set to Level

Specified level Specified level

Data of a specified channel Data of a specified channel
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•	 Data Count (Stop Condition)
	 Logging stops when a specified number of data points is logged.
	 Logging interval = scan interval x recording rate x specified data count.

•	 Fixed Time (Start/Stop Conditions)
	 A time within a 24-hour period (HH:MM:SS.SSS) can be specified. The times of the 

acquired data are scanned, and logging starts or stops when the time of the data 
retrieved from the monitor server is equal to or greater than the specified time.

	 When logging, logging starts when the time of the data retrieved from the monitor 
server is equal to or greater than the specified time. Logging stops when the time of 
the data retrieved from the monitor server is equal to or less than the specified time (the 
specified stop time is not exceeded).

Specified time:
HH:MM:SS.SSS

Logging statusScanning status

Recording starts

Logging starts

Specified time:
HH:MM:SS.SSS

Logging stops Scanning status

Recording ends

Logging stops

Logging starts at affixed time Logging stops at a fixed time

	 For example, if start and stop conditions are set to a fixed time trigger with the start 
time set to 5:00 am and the stop time set to 8:00 pm, logging occurs each day 
between 5:00 am and 8:00 pm.

	 If the start time were set to 8:00 pm and the stop time were set to 5:00 am, logging 
would take place from the evening of the first day to the morning of the second day.

Notes Regarding the Start and Stop Conditions When Alarm or Level 
Triggers Are Specified
•	 Operation if the stop conditions were already met at the point start 

conditions are met
	 Logging starts from the point at which start conditions were met (A), and stop 

condition scanning begins at the same time. At that point (B), stop conditions are met 
but logging is not stopped. Logging stops at point (D) in which stop conditions were 
met after point (C) prior to which stop conditions failed to be met the first time. (See 
the following figure for the letters referred to in the text above)

Start
Condition

Stop
Condition

Logging period

Logging stops

Logging start

A

B C

D

Period during which conditions are met

Period during which conditions are met Period during which conditions are met

Time
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Example:	�When the start condition is to scan for 1 alarm and the stop 
condition is to scan for 2 alarms (OR condition)

	 Logging begins from the point the alarm occurs. At that point (B) the stop conditions 
are met (alarm 1 or 2 is occurring) but logging does not stop. The stop condition’s 
alarm 1 is cleared and reactivated between points B and C’, but logging does not 
stop because stop condition’s alarm 2 is still occurring during that time, and the stop 
condition continues to be met. Both stop condition alarms are finally cleared for the 
first time at point C, making the stop conditions no longer met. Only after that, at point 
D, are stop conditions met again and logging stops. (See the following figure for the 
letters referred to in the text above.)

Start
Condition

Time

Stop
Condition

Alarm 1

Alarm 1

Alarm 2

Logging period

Logging stops

Period during which alarms 
are occurring

Logging start

A

B C

C’

D

•	 Operation if the start conditions were already met at the point stop 
conditions are met

	 Logging stops at the point at which stop conditions were met (A), and start condition 
scanning begins at the same time. At that point (B), start conditions are met but 
logging is not stopped. Logging starts at point (D) in which start conditions were met 
again after point (C) prior to which start conditions failed to be met the first time. (See 
the following figure for the letters referred to in the text above.)

Start
Condition

Time

Stop
Condition

Logging period Logging period

Logging starts

Logging stops

B

A

C D

Period during which 
conditions are met

Period during which 
conditions are met

Period during which 
conditions are met
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Example: �when the start condition is to scan for 2 alarms and the stop 
condition is to scan for 1 alarms (OR condition).

	 Logging stops at the point stop condition alarm 1 occurs. At that point (B) the start 
conditions are being met (alarm 1 or 2 is occurring) but logging does not start. The 
start condition’s alarm 1 is cleared and reactivated between points B and C’, but 
logging does not start because start condition’s alarm 2 is still occurring during that 
time, and the start condition continues to be met. Both start condition alarms are 
cleared for the first time at point C, making the start conditions no longer met. Logging 
finally starts thereafter at point D, when the start condition is met again. (See the 
following figure for the letters referred to in the text above.)

Start
Condition

Time

Stop
Condition

Alarm 1

Alarm 1

Alarm 2

Logging period Logging period

Logging stops

Period during which alarms are occurring

Logging starts

C

C’

B D

A

Pretrigger Function
If the start condition is an alarm trigger or level trigger, you can use a pretrigger function. 
The pretrigger function allows you to save only the specified number of data prior to the 
trigger start point. The number of data specified does not include the trigger point itself. 
The pretrigger function can be set in the range from 0 to 1799 data points. If you specify 
0 data points, the pretrigger function is effectively disabled.

Number of Pretrigger Data Specified and the Recording Rate
When data is saved to a file, it is first thinned at the specified recording rate. The number 
of data specified for the pretrigger represents the number of data after thinning. The 
internal memory can save up to 1800 data acquired from the monitor server (see page 
1-2, “AddTrigger Structure”). Because of this, the valid range for the data that can be 
specified for the pretrigger varies depending on the recording rate. That range is from 0 
to (1800 ÷ the recording rate) - 1.
For example, the recording rate in the figure below is 3, so the valid range is from 0 to 
599.

		

Recording rate

Recording rate

Start trigger

1800 data

Data to be logged



1-10 IM WX13-01E

1.1  Overview of Functions

Terminology for the Period of Data That Is Saved When Setting the 
Pretrigger
Data held before the start trigger
	 The area held in the internal memory that is prior to the point when the start trigger 

condition is met.
Pretrigger width
	 The period including the number of pretrigger data specified in the start conditions.
	 Pretrigger width = scanning interval x recording rate x pretrigger count.
Data saving period
	 The period during which data is saved.
Start trigger point
	 The point in time at which the start condition changes from being unmet to being met.
Stop trigger point
	 The point in time at which the stop condition changes from being unmet to being met.
Start point of data saving
	 The first data of the data saving period.
Specified width for data saving
	 The period including the number of data specified in the stop conditions.
	 Specified width for data saving = scanning interval x recording rate x data count.

When the Stop Condition Is Set to Alarm Trigger, Level Trigger, or Fixed 
Time
When the stop condition is set to Alarm Trigger, Level Trigger, or Fixed Time, data are 
saved from the number of data specified for the pretrigger that are prior to the start 
trigger point (start point of data saving) up to the start trigger point. Then, scanning is 
performed on the data from the start trigger point up to the point specified in the stop 
conditions, and that data is saved. In this case, the relationships between the data held 
before the start trigger and the pretrigger width are shown in the figure below.
	� Data held before the start trigger > pretrigger width (most common 

case)
Data held before the start trigger

Pretrigger width

Start point of data saving
Start trigger point Stop trigger point

Time

Data saving period

	 Data held before the start trigger < pretrigger width
Data held before the start trigger

Pretrigger width

Start point of data saving
Start trigger point Stop trigger point

Time

Data saving period
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When the Stop Condition is Data Count
When the stop condition is set to Data Count, data are saved from the number of data specified 
for the pretrigger that are prior to the start trigger point (start point of data saving). Then, the 
specified number of data are saved, and logging stops. In this case, the relationships between 
the data held before the start trigger and the pretrigger width are shown in the figure below.

Data held before the start trigger > pretrigger width (most common case)
•	 Pretrigger width < Specified width for data saving [2]

Data held before the start trigger

Pretrigger width

Start point of data saving Start trigger point
Time

Data saving period (Specified width for data saving)

•	 Pretrigger width > Specified width for data saving

Data held before the start trigger

Pretrigger width

Start point of 
data saving

Start trigger point
Time

Data saving period 
(specified width for data saving)

Data held before the start trigger < pretrigger width
Attempts to save the specified number of data starting from the point that is one pretrigger 
width behind the start trigger point. However, since that point does not satisfy the condition, 
data held before the start trigger < pretrigger width, no data is saved. In this case, the data 
at the start point of data saving lies beyond the starting point based on the pretrigger width. 
Because of this, the number of data saved is less than the specified number of data.
There are three periods for data saving:
•	 When the data saving period exists (including the start trigger point)
•	 When the data saving period exists (not including the start trigger point)
•	 When the data saving period does not exist
Each case is shown in the figure.

•	 When the data saving period exists (including the start trigger point)
Pretrigger width < (specified width for data saving + data held before 
the start trigger) (most common case)

Data held before the start trigger

Pretrigger width

Start point 
of data saving

Start trigger point
Time

Data saving period

Specified width for data saving
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	 •	� When the data saving period exists (not including the start trigger 
point)

	 Pretrigger width < (specified width for data saving + data held before the start trigger) 

		

Data held before the start trigger

Pretrigger width

Start point 
of data saving

Start trigger point
Time

Data saving period

Specified width for data saving

	 •	 When the data saving period does not exist
	 Pretrigger width > (specified width for data saving + data held before the start trigger) 
	 Data is not saved.

				  

Data held before the start trigger

Pretrigger width

Start trigger point
Time

Specified width for data saving

When specifying a pretrigger, depending on the gap in occurrence of the start trigger, the 
saving area in both triggers may overlap.

When the saving areas do not overlap

		

Data holding period 1

Pretrigger width

Start trigger point 1 Stop trigger point 1

Time

Data holding period 2

Pretrigger width

Start trigger point 2 Stop trigger point 2

When the saving areas overlap
(both files contain overlapping saved areas)

Data holding period 1

Pretrigger
width

Pretrigger
width

Amount of 
logging data

Amount of 
logging data

Start trigger point 1 Stop trigger point 1

Data holding period 2

Start trigger point 2 Stop trigger point 2

Time
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Trigger Confirmation Count
When Alarm or Level is specified as the logging start/stop condition, you can set 
AddTrigger to start or stop logging when a trigger condition is detected consecutively the 
specified number of times (trigger confirmation count).
This allows you to prevent undesirable triggers from occurring due to changes in the 
measured data caused by noise and other factors.

Scan interval

No logging Logging period
indicates the point when 
end condition is monitored.
indicates the point when 
start condition is monitored.

Time

Example in which the trigger confirmation count is set to 3

Logging start trigger condition 
is met three consecutive times.

Logging end trigger condition 
is met three consecutive times.

indicates the point when 
the start condition is met.
indicates the point when 
the end condition is met.

Trigger Repeat Count
For example, if logging is started after an alarm activates after record start, and logging 
is stopped after the alarm is cancelled, you can specify the number times to execute the 
logging start/stop operation (trigger count).
When the specified number of logging start/stop operations is executed, recording stops.

Logging by specifying the trigger count

Scanning status Scanning status Scanning
statusLogging status Logging

status
Logging

status

Logging start Logging stop

Start trigger point Stop trigger point

Record start Record stop

Execute the logging for the 
specified trigger count time1st time 2nd time

Saving Data Files
•	 File Name
	 File names are automatically assigned to data files. You can add a specified character 

string or date to the file name. The extension is .mld.
	 Specified character string (when per Hour division is set) = YYYYMMDDHH-0000.mld 

(see description below for the per Hour setting).
	 Specified character string (for settings other than per Hour) = YYYYMMDD-0000.mld.
	 YYYYMMDD, YYYYMMDDHH: date and time logging started
	 YYYY: year, MM: month, DD: date, HH: hour
	 0000: sequence number. The sequence number increments by 1 every time a file is 

saved.

Note
•	 You can specify whether to add a character string or date to the file name. If neither is 

added, the file name becomes 0000.mld.
•	 If logging is started at 9 hours 10 min 25 seconds on February 26th, 2002, the YYYYMMDD 

section of the file name becomes 20020226. If set to per Hour, it becomes 2002022609.
•	 If a file with the same name exists, the sequence number is increased to create a unique 

file name. The sequence number following 9999 (4 digits) is 10000 (5 digits). The number 
following 99999 (5 digits) is 100000 (6 digits), and so on.
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•	 Saving the Data to a Single File or Multiple Files
	 The data in the logging period can be divided and saved in the following fashion.
	 Data count: 	 When a specified number of data points (logging count) is written to a 

file, AddTrigger starts writing data to a new data file. The number of data 
points of the last data file to which data is written may be less than the 
specified number of data points.

	 per Day:	 AddTrigger starts writing data to a new data file at 0 hour 0 min 0s every 
day.

	 per Hour:	 AddTrigger starts writing data to a new data file at 0 min 0s every hour.

Saving to a single file

		
XX:00:00 XX:00:00

00:00:0000:00:00

Save to a single file

Data count division

per Hour division

per Day division

Logging period

Logging period Logging period

Logging period

Logging period

Logging period

Logging period

Logging period

Number of data points for dividing the file

Time

Time

Time

Time
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Channel Settings
Information is gathered from the host, and the channel name, tag number, tag comments, 
min/max values, units, and alarm settings are displayed. You can also turn scanning and 
recording ON or OFF.

Group Settings
From the channels defined in the connected data logging software, you can assign the 
channels from which data will be logged to groups. Up to 32 channels can be assigned 
per group. A single channel can be assigned to multiple groups.

To use group settings already entered on the connection destination (the data logging 
software), obtain them from the connection destination’s monitor server, and copy the 
channel assignments in the logging settings and their display settings to the logging start/
stop settings.
You can select any number of the following items to copy.

•	 Display ON/OFF
•	 Channel/tag no./tag comment
•	 Y-axis show/hide and category
•	 Numerical display format (floating point or exponential display)
•	 Meter type
•	 Scale value setting method (obtain from monitor server/user-specified) 
•	 Scale (min, max)
•	 Zone (min, max)
•	 Trip point
•	 Display color

Comment Settings
You can add up to eight comments. Comments include an item name and the comment 
itself. The number of allowed characters for each is as follows:
	 Item name:		 16 alphanumeric characters
	 Comment:		  64 alphanumeric characters
Comments are displayed as data file information.

Automatically Converting the Data Format
The file format for logged data can automatically be converted to ASCII, Lotus, or Excel 
format and saved as a separate file. Converted files are saved to a specified folder.
The names of the converted files are as follows:
•	 Converted to ASCII: original file name.txt
•	 Converted to Excel: original file name.xls
	 The file can be opened on Excel version 4.0 or later.
•	 Converted to Lotus: original file name.wj2
	  The file can be opened on Lotus1-2-3 version 2.0 or later.

Note
•	 If a file with the same name exists, the file name takes the following form.
	 original file name_0000.extension
	 0000: sequence number. The sequence number following 9999 (4 digits) is 10000 (5 digits). 

The number following 99999 (5 digits) is 100000 (6 digits), and so on.
•	 There is a limit in the number of data points that Excel and Lotus1-2-3 can handle. Note that 

even if the number of data points is within the limits, loading the converted data may not be 
possible if the available free memory on the PC is insufficient.
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Miscellaneous
Relationship between the Logging Start/Stop Conditions and Special Data
The data that the data logging software scans and records contains the special data 
listed below. AddTrigger retrieves these types of data.
•	 +OVER: data exceeding the high limit of the measurement range
•	 –OVER: data below the low limit of the measurement range
•	 LACK: data dropout
•	 OFF: When data cannot be scanned and recorded because the communication with 

the recorder was cut off.

If the logging start condition/stop condition is set to Alarm or Level and the trigger 
monitoring channel contains special data, AddTrigger behaves as follows:
•	 Positive overflow and negative overflow are ignored by the trigger monitoring process.
•	 LACK and OFF are not used by the trigger monitoring process (trigger is not activated 

while LACK or OFF is present)

Reconnection Procedure with the Data Logging Software
If communication with the data logging software is cut off or the initial communication 
connection fails due to a network failure or other factors, AddTrigger attempts to 
reconnect. If an error occurs during communication, attempts to reconnect are made at 
the timing of the scan interval. 
In the case of failure to connect initially, the attempt to reconnect is made 30 s after the 
communication failure. If communication in progress is cut off, the attempt to reconnect 
is made at the scan interval. Attempts to reconnect are made continuously until a 
connection is established, or until the user cancels the operation.
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1.2	 PC System Requirements and Data Logging 
Software That Can Be Connected

PC System
•	 Supported Operating Systems (OS)
	 Run DAQWORX under any of the following operating systems.

•	 Windows 2000 Professional SP4
•	 Windows XP Home Edition SP2
•	 Windows XP Professional SP2 (excluding Windows XP Professional x64 Edition)
•	 Windows Vista Home Premium (excluding the 64-bit edition)
•	 Windows Vista Business (excluding the 64-bit edition)

	 The language displayed by the software under different language versions of the OS 
are as follows.
OS Language Software Language
Japanese Japanese
Other English

•	 File System
	 NTFS is recommended. With FAT32, the number of files that can be saved in a single 

folder is much smaller. If the limit is reached and additional files cannot be saved, the 
software will not function normally. To prevent this, please periodically stop recording 
by the software and move the data to a different folder.

•	 PC
	 A PC that runs one of the OS above, and that meets the following CPU and memory 

requirements.
	 When Using Windows 2000 or Windows XP
	 Pentium 4, 1.6 GHz or faster
	 512 MB or more of memory
	 When Using Windows Vista
	 Pentium 4, 3 GHz or faster
	 2 GB or more of memory

•	 Hard disk
	 Free disk space: 200 MB or more (more may be required depending on the amount of 

data to be acquired.)

•	 CD-ROM Drive (for Use during Installation)

•	 Mouse
	 A mouse supported by the OS.

•	 Monitor
	 When Using Windows 2000 or Windows XP
	 A monitor supported by the OS of 1024 × 768 dpi or higher and 65,536 colors or more.
	 When Using Windows Vista
	 A video card recommended for use with Vista and a monitor supported by the OS of 

1024 × 768 dpi or higher and 65,536 colors or more.

•	 Communication Port
	 Ethernet port supported by the OS.
 

•	 Printer (Used When Printing)
	 Printer and printer driver supported by the OS
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Note
•	 If you continuously perform multiple data logging operations simultaneously using this 

software, fragmentation occurs in the free space on the disk to which data is saved. As 
fragmentation progresses, contiguous free space decreases and large data files are divided 
into pieces when they are saved. As a result, the processing time of the OS increases and 
may degrade the performance of the data logging operation. To prevent this from happening, 
it is recommended that free space be defragmented periodically using a disk optimization 
tool such as the Windows Disk Defragmenter.

	 The phenomenon described above occurs more often on Windows 98/Me systems.
•	 This software cannot process data after 2038.
•	 We recommend that you back up all saved data.

Connectable Data Logging Software
AddTrigger can connect to the following data logging software. We recommend that you 
use the newest version to lessen the data communication load and make high-speed 
communications possible.
•	 DAQ32Plus R9.01 or later (R10.03 or later recommended)
•	 DAQLOGGER R3.01 or later (R5.01 or later recommended)
•	 MXLOGGER R1.01 or later

Note
Of the various types of systems, only one can be connected when connecting to MXLOGGER.
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2.1	 Setup Flow

A setup flow chart is shown below.

		

Prepare the data logging software 
to which AddMulti is to be connected

Start AddTrigger

Set a project

• Set the connection destination
• Retrieve and display host information
• Set the logging conditions
• Set the display conditions

Set the data logging conditions

Start data logging (section 3.2)

Section 3.1

Section 2.2

• Create a new project
• Copy a project
• Switch the project
• Change the password
• Delete a project

Section 2.3

Section 2.4
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Starting AddTrigger
Procedure

From the Windows Start menu, choose Programs > YOKOGAWA DAQWORX > 
AddTrigger > Launcher.
The Launcher window appears.

		

Note
•	 The project that opens when AddTrigger is started is the project that was open the last time 

you exited the program. If the file list was displayed the last time you exited the program, the 
file list appears when you start the program this time.

•	 If the Use Password Protection check box is selected for the project, the Launcher starts 
with password protection enabled. For the procedure for canceling the password protection, 
see section 3.4.

•	 For instructions on how to switch the project, see section 2.3.

Exiting AddTrigger
Note

Disconnect AddTrigger from the data logging software before exiting the Launcher.

Procedure
1.	 Choose File > Exit, or click the X button in the right corner of the title bar.

	 If no other software programs are running, AddTrigger closes.

		  When Other Programs Are Running
	 If programs other than Launcher are running, the following dialog box opens.

					   

2.	 Click Yes or No.
	 Yes:	�Save the current settings and exit AddTrigger. When AddTrigger is started 

the next time, the current settings are restored.
	 No:	 Do not save the current settings, and exit AddTrigger.
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2.3	 Setting Up Projects

A project is a group of settings required for operating AddTrigger. You can create as 
many projects as you like and save them.
By switching projects, you can easily switch between different sets of AddTrigger 
settings.

Note
You cannot carry out the operations described below if scanning is in progress or when 
Programs other than the Launcher are running.

Creating a New Project
Procedure

1.	 Choose File > Project Settings from the Launcher menu bar. The Project Setting 
dialog box opens.

					   

	 By default, the new project is registered under the name Project1.

2.	 Click New. The New Project dialog box opens.

					   

3.	 Enter a project name and click OK. A new project is created.

Note
•	 Enter a project name using up to 16 alphanumeric characters.
•	 The project name may not contain any of the following characters: \ / : , ; * ? ”< > |.
•	 A project name may not start with a period.
•	 You cannot create a project with the same name as another existing project.

4.	 To use password protection, select the Use Password Protection check box.

	 The New Password Setting dialog box opens.
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5.	 Enter a password in the New Password and Confirm boxes and click OK.

Note
•	 The password is used to open the project and cancel the password protection (see section 

3.4). 
•	 Enter a password using up to 16 alphanumeric characters. There are no restrictions on the 

characters that can be used.
•	 Do not forget the password (we recommend writing it down for future reference).

Begin Scanning or Recording When Launcher Starts
6.	 Click one of the option buttons to select the auto startup function.

	 Off: 	 Disables the auto startup function.

	 Only scan measurement data: 	 Start scanning when the Launcher is started.

	 Scan and record measurement data: 	� Start scanning and recording when the 
Launcher is started.

7.	 Click OK.

	 The settings are saved, and the dialog box closes. The changes you make to the 
settings after this point apply to the new project.

	 Click Cancel to cancel the settings. A new project is not created in this case.

Note
The settings that exist when you quit the Launcher or switch to another project are saved to the 
current project.

Copying a Project
Carry out the following procedure to copy the settings of another project to the currently 
Selected project.

1.	 Choose Project Copy from the File menu.

	 The Copy Project dialog box opens.

					   

2.	 Choose the copy source project from the list box.

3.	 Click OK.

	 The settings of the copy source project are copied to the currently opened project. 

Note
This menu cannot be selected if only 1 project has been created (such as the first time using 
the program).
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Switching the Current Project
Carry out the following procedure to switch to a different project.

Procedure
1.	 Choose File > Project Settings from the Launcher menu bar. The Project Setting 

dialog box opens.
2.	 Choose the desired project from the Project list box.

					   

3.	 If the Use Password Protection check box is selected in the project that you 
selected, the Password Input dialog box opens.

					   

4.	 Enter the password and click OK. The dialog box closes.

5.	 Click OK. The Project Setting dialog box closes and the selected project is 
opened.

Note
If the file list was displayed in the selected project the last time you exited the program, the file 
list appears when you start the program this time.

Changing the Password
Carry out the following procedure to change the password when you are using the 
password protection.

Procedure
1.	 Choose Project Settings from the File menu. The Project Setting dialog box 

opens.
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2.	 Click Change. The New Password Setting dialog box opens.

					   

3.	 Enter a password in the New Password and Confirm boxes and click OK.

Note
•	 Enter a password using up to 16 alphanumeric characters. There are no restrictions on the 

characters that can be used.
•	 Do not forget the password. 

Deleting a Project
Carry out the following procedure to delete a project.

Procedure
1.	 Choose Project Settings from the File menu. The Project Setting dialog box 

opens.

					   

2.	 Choose the desired project from the Project list box.

3.	 Click Delete.

Note
•	 If only a single project exists, you cannot delete the project.
•	 Even if you delete the project, the folder containing the setup file for the project remains 

(AddTrigger installation folder\project name). If you create a project with the same name as 
the deleted project, the remaining setup file is loaded and the information is displayed. If you 
wish to display the project in the default condition, change the folder name of the deleted 
project, move the folder to another folder, or delete the folder using the Windows Explorer or 
a similar utility.
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2.4	 Entering Data Logging Conditions

This section describes how to enter the data logging conditions such as the connection 
destination, logging interval, and logging start/stop conditions.
The display conditions used when displaying the logged data using Historical Viewer are 
also described.

Logging Settings
You can enter the host name, port number, and system number of the PC running the 
monitor server. The server type, number of channels, scanning interval, and start time 
are downloaded and displayed.

Procedure
1.	 Click Configuration on the toolbar or choose Logger > Configuration from the 

menu bar.

	 The Configuration dialog box opens.
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Entering the Host Name
2.	 Click the Server Host text box, then enter the host name of the PC running the 

monitor server.
Entering the Port Number

3.	 If the server is DAQ32Plus, DAQLOGGER, or MXLOGGER, click the Port No. text 
box and enter the port number.

	 If the server is DAQ32Plus, DAQLOGGER, or MXLOGGER, click the Select Port 
Number button.

					     Port number selection button

	 A dialog box used to select the port number appears. Click the desired port 
number.

					   

	 The port number is entered in the text box.

Entering the System Number
The system number is used to identify data sources when more than one source is being 
accessed by the monitor server. To determine whether a system number is required for 
the monitor server being used, see the user’s manual for that monitor server.

4.	 Click the System No. text box and enter the number.

					   

Retrieving and Displaying Host Information
5.	 Click Get Host Info.

			   The Information dialog box opens.

					   

	 The user type, number of channels, scan interval, and scan start time are 
displayed in the upper part of the Configuration dialog box.

	 If a connection could not be made to the monitor server, an error message dialog 
box appears. Check the connection settings to confirm that they are correct.

					   

Note
When you click Get Host Info., a connection is made with the monitor server, the following 
information is downloaded, and then the connection closes.
• Channels			   • Number of channels
• Scan interval		  • Scan start time
• Tag numbers		  • Tag comments
• Max./min. values		  • Units
• Server type			   • Alarm settings (level, type, value)
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Basic Operation
Restrictions When Using the Configuration Dialog Box
The following restrictions apply when using the Configuration dialog box.
•	 If password protection is ON, all operations are disallowed.
•	 If password protection is OFF and scanning is in progress, only the host name and 

port number can be changed.
•	 If password protection is OFF and recording is in progress, all operations are 

disallowed.

Note
You can select a channel identifier of Channel No., Tag No., or Tag Comment. In the 
explanations below, the channel identifier is set to Channel, but you can substitute Tag No. or 
Tag Comment according to your situation.

Procedure

		

Select all (ON/OFF) Channel identifier switching button

Waveform number/channel number
Selection button

Selection button
Toggles USER and CH

Click the channel identifier switching button to switch the display in these cells

Switching the Channel Identifier
	 Click the button at the upper right corner to switch between Channel No., Tag No., and 

Tag Comment.
Selecting the Waveform Number or Channel Number

•	 To select a range of waveform or channel numbers consecutively, click the first 
waveform cell, and then hold down the SHIFT key while clicking the last cell. You 
can also drag the cursor from the first waveform number to the last.

•	 To select all waveform numbers or channel numbers, click the No. cell. The 
waveform or channel numbers are displayed in blue. To cancel the selection, click 
the No. cell again.

Note
Clicking the shortcut button when no waveform/channel numbers are selected achieves the 
same result (selects all).
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Switching the Display ON/OFF, and Selecting/Clearing Items
	 When you click a check box, the box’s color switches from blue to Gray.
	 Blue: display ON, selected
	 Gray: display OFF, cleared

Clicking to Change Settings
	 For the setting items in the figure below, clicking the cell causes the setting item to 

change.

			   	

	 You can change the alarm trigger under logging settings, the direction under level 
trigger settings, the Y-axis under group settings, the alarm level under channel 
settings, and others.

Using the Shortcut Buttons (Operation When Setting the Display 
Conditions)
	 There are five types of shortcut buttons.

A B A AD A C E E D D A E A E E

	 Short cut buttons allow you to enter settings into each item of a range of selected 
waveform numbers. If a range of waveform numbers is not selected, the action applies 
to all waveform numbers.
A: Shows, hides, or sets the selected items in the column.
B: Channel numbers are filled from the first cell in the selection to the last, each 

channel being assigned a number 1 higher than the last.
C: Switches the meter type of the selected range.
D: Copies the first value in the selected range to all items in the selected range.
E: Sets the selected values to their defaults.

Applying the Display Condition Settings to the Display Conditions of Data 
Monitor
	 Select the Updates display settings to Data Monitor check box. The settings are 

applied to Data Monitor when you click Apply or OK. However, Data Monitor must be 
running in this case.

Saving the Settings
	 Click Apply to save the settings. In this case, the Configuration dialog box remains 

open. 
	 Click OK to save the settings and close the Configuration dialog box.
	 Click Cancel to cancel the settings and close the Configuration dialog box.
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Entering Logging Settings
Procedure

Click the Record tab. 

		

Recording Rate
	 The logging interval is specified in integral multiples of the scanning interval. An 

integer from 1-120 is specified for the recording rate setting. The logging interval is the 
product of the integer specified here and the scanning interval, and is shown in the 
right of the text box.

1.	 Click the Recording rate box and enter an integer value.

					   

Repeat Counts
	 You can specify the number of times logging is performed.

1.	 Click the Repeat counts box and enter the number of times to perform logging. 
You must enter a number of 1 or larger.

					   

2.	 Select the Repeat counts check box. Logging ends after the specified number of 
times.

	 If the check box is clear, the trigger count is unlimited. In this case, the user must 
stop logging manually.

Note
If you stop recording manually while in progress, logging occurs right up to the point where the 
operation was stopped.
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Start Condition
1.	 Click to display the list, then select Alarm, Level, or Daily fixed time.

	 Alarm:	 The specified alarms on the specified channels are scanned, 
the trigger is activated if the conditions are met according to 
the statuses of those alarms, and logging begins.

	 Level:  	 The data on the specified channels is scanned, the trigger 
is activated if the conditions are met according to the 
relationship between the level values specified for those 
data, and logging begins.

	 Daily fixed time:	 AddTrigger scans the time of the logged data, and when 
the time specified for each day is reached or exceeded, the 
trigger is activated and logging begins.

	 Configuring the Alarm Trigger
2.	 Click Configuration to open the Alarm Trigger Configuration dialog box.

		

Click to change the item

Paste

3.	 Select AND or OR for the calculation.

	 AND: 	� Activate a trigger and begin logging if all of the specified alarm trigger 
conditions are met.

	 OR: 	� Activate a trigger and begin logging if at least 1 of the specified alarm 
trigger conditions are met.
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4.	 Click the channel to scan.

 	 The Channel No. dialog box opens.

					   

5.	 Click the channel for which you wish to set an alarm. In this dialog box, if the 
channel information of the currently downloaded monitor server information 
applies to the selected scanning channel, the channel is displayed in black. If it 
does not apply, or if it does apply but scanning for that channel is turned OFF (see 
page 2-18, “Channel Settings”), the channel is displayed in Gray.

6.	 Set alarm levels 1 through 4. Click an item to select one of the following settings. 

	 Rise:	 Make the alarm activation the trigger

	 REL:	 Make the alarm cancellation the trigger

	 Off: 	 Do not scan the scan channel.

Each type of alarm level displays the channel information from the currently downloading 
monitor server information.

Paste
	 This button pastes the channel assignments copied when clicking the Copy button 

under Group Settings (see page 2-19) into the Alarm Trigger Configuration dialog 
box. If channels being simultaneously scanned are separated into groups, this Paste 
function instantly copies channels assigned to certain groups to the Alarm Trigger 
Configuration dialog box as scan channels.

Note
•	 If all scan channel alarm level settings are set to Off, those channels are not scanned. This 

is the same as if they had not been registered as scan channels.
•	 If scan channels are not active, or if scan is OFF (colored Gray) and the alarm level is set to 

Rise or REL, those channels’ conditions are always considered to be unmet. A scan channel 
is inactive when scan is turned OFF in the channel settings, or data is not being logged by 
the data logging software on the monitor server.

•	 If the scan channel is active and the alarm level is set to Rise or REL, and if that channel’s 
alarm level is not set on the data logging software, the alarm level condition is always 
considered to be unmet.
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7.	 Click the Pretrigger box, and enter the number of data prior to the point at which 
the trigger conditions are met from which you wish to begin saving data.

Save ime period for the specified data count 
(scan interval x recording rate x pretrigger data count)

Allowed range for the pretrigger setting

	 The setting range is from 0 to 1799 (see page 1-7, “Pretrigger Function”). The 
save time for the specified data is shown in the right of the box. 

	 This value is calculated based on the downloaded scan interval (see page 2-8, 
“Retrieving and Displaying Host Information”). If you click Get Host Info. again 
after changing the scan interval for the connected monitor server, this value also 
is changed.

	 Configuring the Level Trigger
2.	 Click Configuration to open the Level Trigger Configuration dialog box.

					   

Click to display 
the channel dialog box

Selection button

3.	 Select AND or OR for the calculation.

	 AND: 	� Activate a trigger and begin logging if all of the specified level trigger 
conditions are met.

	 OR: 	� Activate a trigger and begin logging if at least one of the specified level 
trigger conditions are met.
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4.	 Click a channel to scan.

	 The Channel No. dialog box opens.

					   

5.	 Click the channel of the level you wish to scan. Here, if the channel settings 
from the currently downloaded monitor server information applies to the selected 
scanning channel, the channel is displayed in black. If it does not apply, or if it 
does apply but scanning for that channel is turned OFF (see page 1-13, “Channel 
Settings”), the channel is displayed in Gray.

6.	 Click a Level value box and enter the value for the reference level.

7.	 Click the Slope box and choose UP or DOWN.

	 UP:	 Starts logging when data from the scanned channel exceeds the level.

	 DOWN:	 Starts logging when data from the scanned channel falls below the level. 
Paste
	 This button pastes the channel assignments copied when clicking the Copy button 

under Group Setting Information (see page 2-19) into the Alarm Trigger Configuration 
dialog box. If channels being simultaneously scanned are separated into groups, 
this Paste function instantly copies channels assigned to certain groups to the Alarm 
Trigger Configuration dialog box as scan channels.

Note
•	 If scan channels are not active and if scan is OFF (colored Gray), those channels’ conditions 

are always considered to be unmet.
•	 If an overrange occurs on the scanned channel (+OVER or –OVER), the value for the 

channel condition is considered to be positive infinity or negative infinity. In other words, 
the level is always considered to have been exceeded on a +OVER, and not reached on a 
–OVER regardless of the scanned channel’s specified level.
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8.	 Click the Pretrigger box, and enter the number of data prior to the point at which 
the trigger conditions are met from which you wish to begin saving data.

Save time period for the specified data count 
(scan interval x recording rate x pretrigger data count)

Allowable rage for the pretrigger setting

	 The setting range is from 0 to 1799 (see page 1-7, “Pretrigger Function”). The 
save time for the specified number of data is shown in the right of the box.

	 This value is calculated based on the downloaded scan interval (see page 2-8, 
“Retrieving and Displaying Host Information”). If you click Get Host Info. again 
after changing the scan interval for the connected monitor server, this value also 
is changed.

	 Fixed Time Trigger Settings
2.	 Click the Time boxes and enter the times at which the trigger activates within a 

24-hour period.

					   

	 The trigger activates when the specified time is reached or exceeded, and logging 
begins.

End Condition
1.	 Click to display the list box, then select Alarm, Level, Daily fixed time, or Data counts.

	 Settings for the alarm trigger, level trigger, and daily fixed time are the same as in 
the start conditions.

	 Setting the Data Count
2.	 Click the Data Counts box and enter a number.

Time required for logging 
(scan interval x recording rate x (specified data count - 1))

	 Logging starts, then stops when the specified number of data points is logged.

	 The time that is required for logging the specified number of data is shown to the 
right of the number of data. It is calculated as the scan interval x recording rate x 
(specified number of data - 1). Therefore if the recording rate or scan interval are 
changed, the logging time also changes.

Note
See page 1-7, “Pretrigger Function” for information about the logging stop point when a 
pretrigger is set (to a value other than 0).

	 File Settings
	 You can specify the data file name, save destination, and how the file is to be 

saved.

Select the file saving method The time required for each data file to be created
The file data length setting is only specified when data counts is selected



2-17IM WX13-01E

Entering Settings (Launcher)

2.4  Entering Data Logging Conditions

1

2

3

4

5

Index

6

Naming Convention (File Name Extension .mld)
File name not specified File name specified

Date not added 0000.mld file name-0000.mld
Add date (file division: per hour) YYYYMMDDHH-0000.mld file name-YYYYMMDDHH-0000.mld
Add date YYYYMMDD-0000.mld file name-YYYYMMDD-0000.mld
(file division: other than per hour)

YYYY is the four-digit year, MM is the month, DD is the date, and HH is the hour. 0000 is the 
sequence number. The sequence number increments by 1 when logging is performed.
If a file of the same name already exists, 1 is calculated for the 4-digit sequence number. The 
sequence number following 9999 (4 digits) is 10000 (5 digits). The number following 99999 (5 
digits) is 100000 (6 digits), and so on.

	 File Division Types
	 OFF: 	 Saves all the data in the logging period to a single file.
	 Data count:	When a specified number of data points (logging count) is written to a 

file, AddTrigger begins writing to a new data file. Enter the number of 
data per division. The time required to create a data file is displayed to 
the right of the number of data per division.

	 per Day:	 AddTrigger writes data to a new data file at 0 hour 0 min 0s every day. 
	 per Hour: 	 AddTrigger writes data to a new data file at 0 min 0s every hour.

	 Specifying an Output Destination
1.	 Click the Browse button.

2.	 Select a folder in which to save data, or create a new folder. The new location of 
the output folder is registered.

	 Entering a File Name

3.	 Select the Extra File Name check box. If the box is not selected, no name will be 
registered even if one is entered.

4.	 Click the Extra File Name box and enter the desired file name. The file name must 
not contain any of the following characters: \ / : , ; * ? ”< > |.

5.	 Select the Add date check box. No date will be added unless the check box is 
selected.

	 Selecting the File Saving Method

6.	 Click to display the File division list and select the division method.

7.	 If Data count is selected, enter the number of data per division.

Trigger Confirmation Count
	 Logging starts/stops when a trigger condition is met consecutively the specified 

number of times (trigger confirmation count).
	 This item is available only when Alarm or Level is specified for the start condition.

1.	 Click the Threshold text input box and enter the confirmation count.

	 The time required for the confirmation is shown to the right of the count.

					   
Confirmation time = scan interval x (trigger confirmation count - 1)
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Channel Settings
Select channels to which channels and data files acquired from the monitor server are 
saved. Also, the channel information (channel name, tag number, tag comment, max 
value, min value, units, and alarm settings) obtained using the procedure described in 
Retrieving and Displaying Host Information (see page 2-8) is displayed.

Procedure
	 Click the Channel tab.

					   

ON/OFF switching Switches the selected item

Turning Scanning ON/OFF on Selected Channels
1.	 Click the cell for a channel to turn scanning ON or OFF.

	 Channels set to ON are loaded from the monitor server.
Turning Recording ON/OFF on Selected Channels

2.	 Click the cell for the channel to turn recording ON or OFF.

	 Data from channels set to ON are saved to a file.

Note
•	 When you turn recording ON, scanning for that channel is turned ON automatically.
•	 When you turn scanning OFF, recording for that channel is turned OFF automatically.

Switching the Alarm Setting
	 Each time you click the cell for the level of the alarm information, the setting 

scrolls through the following options: L1->L2->L3->L4->L1.

Turning Scanning and Recording ON/OFF, and Switching All Alarm Levels 
at Once

1.	 After selecting channel numbers, click the shortcut button to switch the channels 
and levels.

	 See page 2-9, “Basic Operation” for details.

Note
Channel setting items other than ON/OFF for scanning and recording are not changed. They 
are simply displayed for your reference.
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Group Settings
These group settings are saved to data files, and when data files are displayed on data 
viewer (see chapter 5) these settings are also displayed. You can also apply the display 
conditions modified here to Data Monitor (see chapter 4).

Procedure
	 Click the Group tab.

Channel to be registered
Group name ColorDisplay rangeMeter type

Set the trip point.Show or Hide Group tab Zone (display position)
Turn ON/OFF the 
trip line display

Floating point/exponential 
display

Bar meter
Analog meter

Thermometer
Y-axis display

Axis type USER/CH switching (user settings/server settings)
CH: the max and min values of the channels assigned 
       to record start time are obtained.
USER: the values entered into the box are set as the 
            max and min values.

Selecting a Group
Click a group tab to select the group.

Group Name
Click the Group Name box and enter the group name using up to 16 alphanumeric 
characters.

Showing/Hiding the Waveform
Select the No. check box.
	 Blue: 		  Shows the waveform.
	 Gray:			  Hides the waveform.

Y-Axis
You can specify whether to show or hide the Y-Axis (scale) when Multi-Axis Zone is 
selected. Click the check box.
	 Blue: 		  Shows the Y-axis.
	 Gray: 		  Hides the Y-axis.
Specifies the axis type. Linear and Log toggle each time the box is clicked.
	 Linear:		  Linear scale.
	 Log:			   Logarithmic scale.
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Display
Set the display format for numeric values. Select floating-point (100.0) or exponential 
(1.000E2). Floating-point and exponential toggle each time the box is clicked.

Meter Type
Click one of the option buttons to select the type of meter to be displayed on the meter 
monitor of Data Monitor from bar meter, analog meter, and thermometer. The setting is 
not used on Historical Viewer.

Scale
•	 Detail
	 Select whether to use user settings or server settings for the scale settings.
	 CH:	 The max and min values of the channels assigned to the recording start 

time are obtained from the monitor server and set to the scale max and min 
values.

	 USER:	� The values entered into the box are set as the max and min values.		
When selecting USER, you can change the max and min value settings.

•	 Max. value, min. value
	 Click the value boxes to enter the maximum and minimum values of the scale.
	 The range of values that can be entered is from –999999999 to 999999999 excluding 

the decimal point.
	 If you set the minimum value larger than the maximum value, the waveform is 

inverted.

Note
The decimal point position of the entered value is adjusted according to the number of 
significant digits to the right of the decimal point.

Zone
Click the value boxes to enter the maximum and minimum values of the waveform 
display zone. The range of values that can be entered is 0 to 99% for the minimum value 
and 1 to 100% for the maximum value.

Trip 1 and Trip 2
Click the value box and enter the position of the trip line within the scale range.
When you enter a value, the check box turns blue. If you do not wish to use the trip line, 
clear the check box.
	 Blue: 		  Enable.
	 Gray: 		  Disabled.

Note
Trip line 1 and 2 are displayed in red and blue, respectively.
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Color
Set the waveform display color.

1.	 Click the Color box.

	 The Color dialog box opens.

					   

2.	 Click a color to select it. Click OK to confirm the new color. The dialog box closes. 

Note
To create a new color, click Define Custom Colors. Use the palette that appears to create the 
new color.

Copying the Group Settings
	 Carry out the following procedure to copy the logging conditions and display conditions 

of a group to another group.

1.	 Click Copy Setting in the Configuration dialog box.

	 The Copy Setting dialog box opens.

					   

2.	 Select the check boxes for the items to be copied and click OK. The dialog box 
closes.

3.	 Click the tab corresponding to the copy source group.

4.	 Click Copy.

5.	 Click the tab corresponding to the copy destination group.

6.	 Click Paste.
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Copying the Group Settings from the Data Logging Software
	 Carry out the following procedure to copy the group settings from the data logging 

software on the monitor server to AddTrigger groups.

1.	 Click Receive Group Settings. The Selection dialog box opens.

2.	 To also copy the group name, select the Get group names check box.

	 Copying between the Same Group Numbers
3.	 Select the All groups check box.

Click to clear all selections
Click to select all items

4.	 Select the check boxes for the groups to be copied.

5.	 Click OK.

	 Copying the Information to the Displayed Group
3.	 Select the Current group check box.

4.	 Select the check boxes for the groups to be copied.

5.	 Click OK.
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Changing Settings
1.	 Click the group number for the settings you wish to change.

2.	 Select the channels you wish to change using the No. check boxes.
	 Specifying Channels

3.	 Click a channel cell. The Channel No. dialog box opens.

					   

Note
Channels not active in the channel settings being downloaded from the monitor server are 
dimmed in the channel information dialog box.

4.	 Select the desired channels.

	 Up to 32 channels can be specified for a group.
	 Entering a Group Name

5.	 Click the Group Name box and enter the group name using up to 16 alphanumeric 
characters.

	 The group settings are applied to Data Monitor and data viewer.
	 The settings entered here are used by data viewer when redisplaying data files. 

Also, you can apply display conditions to Data Monitor.

Applying Display Settings to Data Monitor
1.	 Click the Updates display settings to Data Monitor check box.

2.	 Click Apply or OK.

	 The settings are applied to Data Monitor.
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Comment Settings
Comments related to data logging can be saved to a file. Comments are displayed as 
file information when opening a file on data viewer. They are also written to files when 
converting them to Text, Lotus, or Excel format.
The name of the comment may contain up to 16 alphanumeric characters, and the 
comment itself may contain up to 64 characters.
Up to 8 comments can be entered.

Procedure
1.	 Click the Comment tab.

					   

2.	 Click the name and contents boxes, then enter the necessary information.

Automatically Converting the Data Format
Logged files can be automatically converted every time they are saved. After files are 
saved, no data can be recorded in them.
The available conversion formats are ASCII, Lotus, and Excel, and multiple formats can 
be selected together. You can also specify the division type. A single division type of All, 
channel division, or group division can be selected.
If you select Channel division, the conversion range can also be specified.

Channel Division Settings
Channels can be divided into divisions of 16 or less prior to saving.

Procedure
Click the Conversion tab.

		

Conversion tab
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Selecting the Conversion and Division Types
1.	 Select any number of conversion types. If you do not wish to convert files, clear 

all check boxes.

2.	 Select a division type. If you select Channel, proceeded to Channel Division 
Settings.

Channel Division Settings
•	 Entering Settings One at a Time

1.	 Click the first or last channel number.

	 The Channel No. dialog box opens.

					   

2.	 Specify the first or last channel number.

3.	 Repeat steps 1 to 2 to set channel divisions.

	 •	 Set All Items at Once with the Shortcut Buttons
	 Settings are filled to all items in the selected range based on the start and end 

setting of the first item in the range.
	 If the line number of the first channel is start, and the line number of the last 

channel is end, and N is the number of lines, then the following formula determines 
the start and end channels for the last selected item:

		  start(N) = start + (end – start + 1) x N
		  end(N) = start(N) + (end – start)
	 The channel name/tag number/tag comment assigned to start(N) and end(N) are 

displayed. However, if start exceeds 1600, all lines thereafter are set to NONE. 
Also, if end(N) exceeds 1600, the end channel for that line reverts to 1600. Line 
numbers here are the positions (No. xxxx) of the channel tab settings.

1.	 You can drag in the No. column to select multiple lines.

Note
•	 If no range is selected for items to be set all at once, all lines are considered to be selected. 

Settings are filled to all items in the range based on the start and end setting of the first item 
in the range.

•	 You can change the channel identifier display by clicking Switch Channel Identifier in the 
upper right of the Configuration dialog box.
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2.	 Set the start and end channels for the top line number (see steps 1 and 2 in, 
“Entering Settings One at a Time.”)

3.	 Click the shortcut button.

	 All settings are filled down through the selection.

Saving Modified Files
•	 Specifying an Output Folder
	 Specify the same folder (the output folder specified in the logging setting screen), or 

a separate folder in which to save data files. If you specify a separate folder, you can 
select an existing folder, or create a new folder.

1.	 Select the Same folder as Data File folder or Selects folder check box. If you 
select Same folder as Data File folder, the settings are complete. If you select 
Selects folder, proceed to the next step.

2.	 Click Browse. The Browse folders dialog box opens.

					   

•	 Selecting an Existing Folder for the Output Folder
3.	 Select an existing folder.

•	 Creating a New Output Folder
3.	 Click the location in which you wish to create a folder.

4.	 Click New Folder. The Create New Folder dialog box opens.

					   

5.	 Confirm the current folder, enter a folder name, and click OK. Up to 256 characters 
can be input for folder names. The dialog box closes, and the folder is created.
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2.5	 Changing the Port Number Used by Data 
Monitor

You can change the port number that Data Monitor uses. The new port number is 
activated the next time AddTrigger is started.
The default port number is 50283.
If other applications are not using this port number, you do not have to change it.

Note
•	 Set a value different from port numbers that other applications use.
•	 This port number is not the port number used by the monitor server of the data logging 

software. The port number that the monitor server of the data logging software uses is set in 
“Setting the Connection Destination” in section 2.8.

•	 The port number cannot be changed while scanning is in progress.

Procedure
1.	 Choose File > Port No. for the internal communication. The Port No. for the 

internal communication dialog box opens.

					   

2.	 Enter the port number and click OK. The following message appears.

					   

3.	 Click OK.

4.	 To activate the new port number, exit AddTrigger and restart it.
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2.6	 Displaying the Version and Other Information

	 Click the About Launcher button on the toolbar or choose Help > About.

					   
Version information

	 The About dialog box opens.

					   

Version

Company name

User name

License number

	 Click OK to close the dialog box.
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3.1	 Preparing the Data Logging Software to Which 
AddTrigger Is to Be Connected

Check the following items on the data logging software to which AddTrigger is to be 
connected.

•	 That the monitor server of the data logging software is running.
•	 That the data logging software is scanning.



3-2 IM WX13-01E

3.2	 Scanning and Recording

For the procedure for starting AddTrigger, see section 2.2.
For the procedure for selecting the project, see section 2.3.

		
Record stop

Record start
Scan

Starting the Scanning Operation
Procedure

Click Scan start/stop on the Launcher’s toolbar or choose Scan from the Logger menu. 
AddTrigger retrieves all the data of the related channels that is scanned and held by the 
data logging software.
Scanning starts.

Note
•	 When scanning is started, the monitor server of the data logging software displays the host 

name of the PC on which AddTrigger is running.

						    

•	 If initial communication with the device to be connected fails, a reattempt is made within 30 
seconds after the communication failure was recognized. Additional time is required from 
the start of communication until failure is recognized.

Automatically Starting the Scan Operation
If Only scan measurement data is selected in the project, scanning starts when the 
Launcher is started (see section 2.3).

Stopping the Scanning Operation
Procedure

While scanning is in progress, click Scan start/stop on the Launcher’s toolbar or choose 
Scan from the Logger menu.
Scanning stops.

Note
•	 When scanning is stopped, the host name (of the PC on which AddTrigger is running) that is 

displayed on the monitor server of the data logging software disappears.
•	 You cannot stop the scan operation while recording is in progress.



3-3IM WX13-01E

Logging D
ata (Launcher)

3.2  Scanning and Recording

1

2

3

4

5

Index

6

Starting the Recording Operation
Procedure

1.	 Click Start on the Launcher’s toolbar or choose Start from the Logger menu.

	 Recording starts.

Note
If you carry out the operation to start recording when scanning is not in progress, scanning is 
started first and then recording is started.

Automatically Starting the Recording Operation
	 If Scan and record measurement data is selected in the project, scanning and 

recording start on the specified groups when the Launcher is started (see section 2.3).

Stopping the Recording Operation
Procedure

1.	 Click Record Stop on the Launcher’s toolbar or choose Stop from the Logger 
menu. A confirmation dialog box appears.

					   

2.	 Click OK or Cancel.

	 OK: Stop recording of the group.

	 Cancel: Do not stop recording.
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3.3	 Displaying the Data Logging Status, and 
Deleting the Data File List

You can display the logging status on the launcher. The current data logging status is 
displayed in the upper part of the screen.

The recording status is 
displayed using colors.

If you exit while the data 
file list is displayed, the 
list is redisplayed the next 
time you start the program.

You can drag to select the 
files you wish to display.

The displayed items are as follows:
	 Server Host:		 The connection destination of the currently displayed project.
	 Scan Interval:	 Data logging interval for the currently connected monitor server.
	 Record Interval:	 The interval at which data is downloaded from the monitor server 

and saved, which is the product of the scan interval and the 
recording rate.

	 Record Status:	 Stopped, Scanning, Logging, or Error Stop is displayed. Each 
status is indicated by a colored bar.

				    Stopped: black
				    Scanning: yellow
				    Logging: green
				    Error stop: red
	 Free disk space: 	Shows the currently available space on the data file save 

destination medium.
	 Repeat counts: 	 After recording starts, logging start conditions are met and the 

count at which data saving starts is displayed. When recording 
starts again after stopping, the count is reset to 0.

	 Data counts: 	 The number of data saved when the logging start conditions are 
met. The count is reset to 0 every time saving begins.

	 Start time:		  The date and time data was saved when logging start conditions 
were met, or the date and time when it is set to start is displayed.

	 End time:		  The date and time data was saved when logging stop conditions 
were met, or the date and time when it is set to stop is displayed.

	 Current Data File:	The name of the data file to which logging data is currently being 
written.

	 Convert state:	 The current automatic conversion status is displayed.
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	 Data file list: 	 The information for the data file saved when the launcher was 
started is displayed. When the data file is finished saving, the 
information is added to the display. Information is displayed in the 
order in which it was saved. Up to 200 lines can be displayed. If the 
number of displayed lines exceeds 200, lines are deleted starting 
with the oldest lines to make room for new lines. The list displayed 
before exiting the Launcher is redisplayed when the Launcher 
is restarted and the corresponding project is selected. If data 
files appearing in the list are not present in the folder, that file’s 
information is dimmed.

Displaying the Logging Status
Procedure

You can select a file from the data file list to view the data file currently being logged or 
files that are finished being logged. Also, when browsing the data file list you can stop the 
data from updating so that the screen does not scroll and prevent you from viewing the 
data files that are finished being logged.

Viewing Data Files Being Logged
You can view a data file at the moment it is being saved on Data Viewer. If the data 
being saved was already displayed on Data Viewer, only the data at the point of saving is 
updated and displayed. If the data to be saved changes to a separate data file, the new 
data file is displayed along with all past data files.

Displaying Selected Data Files That Were Previously Logged
You can select any number of files from the list of data files that were previously logged 
and display them on Data Viewer.

Stop Updating of the List of Files That Were Previously Logged
When you stop the updating, newly logged data is not added while browsing logged data. 
Data may be added to the list of logged data files while browsing, causing the display to 
scroll. Stopping the updating prevents this problem.

Clearing the Data File List 
Procedure

You can clear the currently displayed data file list from the Launcher window.
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3.3  Displaying the Data Logging Status, and Deleting the Data File List

Displaying the Logging Data
Procedure

		
Current data Pause updating

Display selected data files

Stop Updating of the List of Logged Files
1.	 Click Updating pause on the toolbar or choose View > Updating pause of the 

data file list from the menu bar.

	 Even if the logging status of the data files currently being logged is Stop, those 
files do not appear in the list of logged files.

Restart Updating of the List of Logged Files
2.	 If you repeat step 1, the logged data files after stopping the update are displayed 

in the list of logged data files.

Displaying Data Files Currently Being Logged in Data Viewer
1.	 Click Current Data on the toolbar or choose View > Current Data File from the 

menu bar.

	 Data Viewer starts, and only the data being saved at that point is displayed.

Displaying Logged Data Files in Data Viewer
1.	 Drag in the list of logged data files to select the items you wish to display.

2.	 Click Display selected Data files on the toolbar or choose View > Selected Data 
Files from the menu bar.

	 The selected data files are all displayed in the viewer.

Note
You can quickly display a file in the viewer by double-clicking the data file (see chapter 5).

Clearing the Data File List 
1.	 Choose View > Erase the data file list.

	 The data file list is cleared. The list cannot be redisplayed once it has been 
cleared.
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3.4	 Using Password Protection

You can use password protection to prevent accidental execution of operations.

Note
Password protection can only be used on a project that is configured to use password 
protection.

Enabling Password Protection
Procedure

Choose Password Protection from the File menu. Password protection is enabled.

Disabling Password Protection
Procedure

Carry out the following procedure to disable password protection.

1.	 Choose Password Protection from the File menu. The Input Password dialog 
box opens.

					   

2.	 Enter the password and click OK.
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3.5	 Using Desktop Protection

The desktop protection is a function used to hide the Windows Start menu and icon on 
the desktop.
When the desktop protection is enabled, other programs cannot be started. This function 
prevents accidental execution of Windows functions that might interrupt AddTrigger 
operations.

Enabling the Desktop Protection
Procedure

1.	 Choose Desktop Protection from the File menu. The Hide Desktop dialog box 
opens.

					   

2.	 Enter a password in the Password and Confirm boxes and click OK.

Note
•	 Enter a password using up to 16 alphanumeric characters. There are no restrictions on the 

characters that can be used.
•	 You can set a different password from the default password.
•	 Do not forget the password.

Disabling the Desktop Protection
Procedure

1.	 Choose Desktop Protection from the File menu. The Input Password dialog box 
opens.

					   

2.	 Enter the password and click OK.
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4.1	 Displaying Waveforms on Monitor Screens

Data Monitor displays the data that is retrieved from the host at the scan interval. The 
following six types of monitor screens are available: Trend, Numeric, Meter, Alarm, Color 
Graph, and Circular. Data Monitor is started from the Launcher.

Note
To change the port number that Data Monitor uses, see section 2.5.

Starting Data Monitor
Procedure

1.	 Click Data Monitor on the Launcher’s toolbar or choose Data Monitor from the 
View menu.

					   

Data Monitor

	 Data Monitor starts and a monitor screen appears.

Menu bar
Toolbar

Status bar

Monitor bar

The latest scan time (Time retrieved 
from the data logging software)

2.	 Click an icon on the monitor bar to open a new monitor screen. You can also 
choose a monitor name from the Window menu to display the monitor screen.

					     Alarm Monitor

Color Graph Monitor
Meter Monitor

Circular Monitor

Numeric Monitor
Trend Monitor

 

Chapter 4	 Monitoring Data (Data Monitor)
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Note
•	 The contents of the menu bar vary depending on the selected monitor screen. The toolbar 

displays all the tool buttons. However, only the buttons related to the selected monitor 
screen can be used.

•	 The number of monitor screens that can be opened is as follows:
	 Alarm monitor:	 1
	 Trend monitor:	 Up to 4
	 Color Graph monitor:	 Up to 4
	 Numeric monitor:	 Up to 4
	 Meter monitor:	 Up to 4
	 Circular monitor:	 Up to 4
	 However, opening multiple monitor screens may degrade the performance.
•	 If for some reason Data Monitor cannot update the scan data, click Connect/Disconnect on 

the toolbar or choose Connect from the File menu. The condition will be recovered.
	 Conversely, if you click Connect/Disconnect on the toolbar or choose Disconnect from the 

File menu when Data Monitor is updating the scan data, Data Monitor stops updating.

					   
Connect/Disconnect

•	 The original project file information is displayed until connection of the initial communication 
with the device to be connected succeeds. When the connection succeeds, the information 
is updated.

Common Operations
Procedure

Linking with Other Monitors
	 When you change the displayed group on one monitor screen or change the channel 

identifier (channel, tag number, or tag comment), you can reflect the changes on the 
other monitors.

	 Click Link on the toolbar or choose Link from the File menu.

			 
Link

Switching the Displayed Group
	 Click the Group tab.
	 The selected group is displayed.

Switching the Channel Identifier (Channel No., Tag No., or Tag Comment)
	 Click Channel No., Tag No., or Tag Comment from the toolbar, or choose Channel 

No., Tag No., or Tag Comment from the View menu.

			 

Channel No.
Tag No.

Tag Comment

4.1  Displaying Waveforms on Monitor Screens
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Pausing Data Monitor
	 Click Pause on the toolbar or choose Pause from the File menu. The updating of the 

display of the monitor screen is paused.
	 Click Pause again or choose Pause from the File menu to resume the updating of the 

monitor screen.

			 
Pause

Note
Data is retrieved even when the display updating is paused. When you resume the display 
updating, the data that was scanned while the monitor screen was paused is displayed.

Arranging the Monitor Screens
	 Choose Tile or Cascade from the Window menu. The multiple monitor screens that 

are displayed are arranged accordingly.

Showing/Hiding the Toolbar, Monitor Bar, or Status Bar
	 Choose Tool Bar, Monitor Bar, or Status Bar from the View menu. The check mark 

next to the item disappears and the relevant bar is hidden. To show the bar, select the 
command again.

Displaying the Launcher in Front
	 Click Launcher on the toolbar or choose Launcher from the View menu. The 

Launcher is displayed in front.

			 
Display launcher in front

Closing the Monitor Screen
	 Click the X button at the right corner of the title bar. The monitor screen closes.

4.1  Displaying Waveforms on Monitor Screens
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Alarm Monitor
You can switch between Overview and Log by clicking the tab.
Overview Display
Displays the alarm conditions by groups.

		

Display Cursor’s Value

Displays the alarm status within the group.

Switch between overview and log

	 Alarm Status Display
	 Green lamp: 	 No alarm is activated in the channels registered in the group 

whose waveform display is turned ON. Or, no alarm is specified 
in any of the channels.

	 Red lamp: 	 Alarm is activated in at least one of the channels registered in 
the group whose waveform display is turned ON.

	 Blinking yellow ring:	Unacknowledged alarms exist.

Acknowledging Alarms
If a blinking yellow ring is displayed around the alarm lamp, there are unacknowledged 
alarms.

Procedure
You can clear the ring by carrying out one of the following procedures.
•	 Click the group on which the blinking ring is displayed.
•	 Choose Alarm Hold Reset from the View menu to clear all the rings that are displayed. 

4.1  Displaying Waveforms on Monitor Screens
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Sounding Alarms and Stopping the Alarm Sound
	 You can have AddTrigger generate an alarm sound whenever an alarm is activated. 

An alarm is sounded only when all the following conditions are met.
•	 The alarm monitor is displayed.
•	 The alarm sound function is turned ON.
•	 Of the channels displayed in the monitor, at least one alarm is activated.

Procedure
Setting the Alarm Sound Function
	 Choose Alarm Sound from the File menu to place a check mark next to the 

command. The alarm sound function is enabled. To disable the alarm sound function, 
choose Alarm Sound from the File menu again to clear the check mark.

Stopping the Alarm Sound
	 You can stop the alarm sound by carrying out any of the following procedures.

•	 Click all the groups on which alarms are occurring.
•	 Choose Alarm Hold Reset from the View menu.

Note
•	 Once an alarm starts sounding, the sound continues until it is stopped even if all alarm 

conditions are cleared.
•	 A sound source is required to sound an alarm.

Log Display
Displays a list of the type and the time of activation and cancellation of the alarms that 
occurred in the past. The newest log is displayed on the last line.
Up to 100 incidents can be displayed. You can scroll the log when display updating of 
Data Monitor is paused.
For operations using the cursor, see section 4.4, “Using Cursors.”

Delay upper limit alarm (red)

Upper limit alarm (red)

Delay lower limit alarm (blue)

Lower limit alarm (blue) Difference upper limit alarm 
(red)

Difference lower limit alarm 
(blue)

Upper limit on 
rate-of-change alarm (red)

Lower limit on 
rate-of-change alarm (blue)

Alarm condition icon (red: occurrence, green: release)
Time of alarm occurrence/release

Channel

Alarm type icon Occurrence/Release
Alarm type character

Alarm level (L1, L2, L3, and L4)

Hiding/Showing the Alarm Type Icons

Procedure
	 Choose Alarm Type Icon from the View menu to clear the alarm type icons on 

the log display. To display the icons, choose Alarm Type Icon from the View 
menu again.

4.1  Displaying Waveforms on Monitor Screens
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Trend Monitor
For the operating procedure, see section 4.3, “Changing the Waveform Display.”
For operations using the cursor, see section 4.4, “Using Cursors.”

Note
Up to 1800 points of data can be displayed (30 minutes when the scan interval is set to 1 s).

Waveform display 
ON/OFF

Select the displayed group
Alarm ON/OFF

Channel No., Tag No., or Tag Comment
Zoom In or Zoom Out of the time axis

Waveform display zone
Clip

Display Cursor's Value
Launcher

Current waveform 
mark

Zone bar

Zone display area

Grid brightness 
adjustment knob

A red bar blinks 
when an alarm occurs. Alarm indication

Absolute or relative time

Zoom factor
Show/Hide zone 
display area

Drag this bar to adjust the 
width of the waveform 
display area when the 
monitor is paused.

Brightness adjustment 
knob of the waveform 
display area

About Data Monitor

Color graph monitor
For operations using the cursor, see section 4.4, “Using Cursors.”

Zoom factor 

Select the displayed group
Channel No., Tag No., or Tag Comment

Zoom In or Zoom Out of the time axis Display Cursor's Value

Waveform display color

Channel No., tag No., 
or tag comment

Color graph
Displays the data by using the 50 different colors that are assigned between 
the minimum and maximum values of the scale.  Assigned in the following 
order: blue (minimum), light blue, green, yellow, and red (maximum).

Absolute or relative timeA red bar blinks 
when an alarm occurs.

4.1  Displaying Waveforms on Monitor Screens
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Changing the Time Axis
	 You can change the time axis display. On the absolute time display, the date is 

displayed at the left end.

Procedure
Choose Absolute Time or Relative Time from the Time-Axis menu.
	 Absolute Time: 	Displays the time.
	 Relative Time: 	 Displays the elapsed time from the first data point.

Numeric Monitor

A red bar blinks when an alarm occurs.

Select the displayed group
Alarm ON/OFF

Channel No., Tag No., or Tag Comment

Alarm indication 
(from the left: 
level 1, 2, 3, and 4)

Waveform display color

Channel No., tag No., 
or tag comment

Bar display of the logged data

Meter Monitor
Select the displayed group

Alarm ON/OFF
Channel No., Tag No., or Tag Comment

Alarm indication 
(from the left: level 1, 2, 3, and 4)

Channel No., tag No., 
or tag comment

Alarm setpoint

A red bar blinks 
when an alarm occurs.

Bar meterAnalog meter Thermometer

4.1  Displaying Waveforms on Monitor Screens
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Circular Monitor
You can display one hour to four weeks worth of data on a circular graph. On the circular 
graph, the radius corresponds to the Y-axis of the trend display, and the circumference 
corresponds to the time axis.

Select the displayed group
Alarm ON/OFF

Channel No., Tag No., or Tag Comment
The red bar blinks when an alarm occurs.

Current waveform mark
Zone display area

Waveform display ON/OFF

Date Absolute or 
relative time Alarm indication

Displayed time per cycle

Brightness adjustment 
knob of the waveform 
display area

Grid brightness 
adjustment knob

Show/Hide zone 
display area

Zoom In or Zoom Out of the time axis
Waveform display zone

Display Cursor’s Value

Circular display channel
Select the current waveform

When monitor paused

		

Cursor

When the monitor is paused

Move the waveform display position (Scroll bar).

For the operating procedures listed below, see section 4.3, “Changing the Waveform 
Display.”
For operations using the cursor, see section 4.4, “Using Cursors.”
•	 Using the waveform display zones (user zone, edit zone, full zone, slide zone, auto 

zone, multi-axis zone).
•	 Showing/hiding alarms.
•	 Specifying the thickness of the waveform display lines.
•	 Changing the time axis display (absolute or relative).
•	 Adjusting the brightness of the waveform display area and grid.
•	 Using cursors.

4.1  Displaying Waveforms on Monitor Screens
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Note
•	 Dragging the Trip Line
	 You cannot drag the trip line on the circular monitor (page 4-17). To change the position of 

the trip line, change the value in the General Display Settings dialog box.
•	 Waveform Display Limit
	 When the measured data is below the minimum display range, the waveform is displayed 

at the minimum value position; when the measured data is above the maximum value, the 
waveform is displayed at the maximum display position.

Setting the Time Axis
Procedure

	 Choose the time per cycle from the Time-Axis menu.

					   

Note
Up to 1800 points of data can be displayed (30 minutes when the scan interval is set to 1 s and 
5 hours when the scan interval is set to 10 s).

Changing the Alarm Indication Position
	 You can select whether alarms are displayed on the inside or the outside of the 

waveform display section of the circular screen.

Procedure
	 Choose Alarm Inside or Alarm Outside from the View menu.

Alarm Inside Alarm Outside

4.1  Displaying Waveforms on Monitor Screens
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4.2	 Setting the Display Conditions

Set the display conditions for each group.
Note

You can select a channel identifier of Channel No., Tag No., or Tag Comment. In the 
explanations below, the channel identifier is set to Channel, but you can substitute Tag No. or 
Tag Comment according to your situation.

Opening Setting Screens
Procedure

	 Click General Display Settings on the toolbar or choose General Display 
Settings from the View menu. The General Display Settings dialog box opens.

					   
General Display Settings

Basic Operation
Procedure

A B A D A C E E D D A E A E E

Show or Hide
Waveform number

A to E are the collective setup buttons (see the next page).

Selecting the Waveform Number
•	 Click the waveform number (in the No. column).
•	 To select waveform numbers consecutively, click the first waveform cell, and then click 

the last cell number while holding down the SHIFT key. You can also drag the cursor 
from the first waveform to the last.

Copying the Group Settings
	 Carry out the following procedure to copy the display conditions from one group to 

another group.
1.	 Click Copy Setting in the General Display Settings dialog box.
	 The Copy Setting dialog box opens.
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2.	 Select the check boxes for the items to be copied and click OK. The dialog box 
closes.

3.	 Click the tab corresponding to the copy source group.

4.	 Click Copy.

5.	 Click the tab corresponding to the copy destination group.

6.	 Click Paste.
Showing/Hiding the Waveform, Y-Axis, Trip 1, and Trip 2

•	 Click the waveform number, Y-axis, trip 1, and trip 2 check boxes to switch between 
show (blue) and hide.

•	 If consecutive cells are selected, you can click the shortcut tool at the bottom of the 
screen to switch the show/hide setting of all the cells in the selected range.

Using the Shortcut Buttons
	 There are five kinds of shortcut buttons.
	 You can enter a setting on every cell in a selected range all at once. If a range of 

items is not selected, the action applies to all items.
A: Shows or hides the selected items in the column.
B: Channel numbers are filled from the first cell in the selection to the last, each 

channel being assigned a number 1 higher than the last.
C: Switches the meter type of the selected range.
D: Copies the first value in the selected range to all items in the selected range.
E: Sets the selected values to their defaults.

Saving the Settings
	 Click Apply to save the settings. In this case, the General Display Settings dialog 

box remains opened.
	 Click OK to save the settings and close the General Display Settings dialog box.
	 Click Cancel to cancel the settings and close the General Display Settings dialog 

box.

Note
If Data Monitor is running, the display settings entered on the Launcher can automatically be 
copied to the general display settings of Data Monitor (see “Basic Operation” in section 2.4).

4.2  Setting the Display Conditions
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Setting the Display Conditions for Each Group
Up to 32 channels can be assigned to a group. A maximum of 50 groups can be used.

Procedure

Channel to be registered
Group name ColorDisplay rangeMeter type

Set the trip point.Show or Hide Group tab Waveform display zone
Turn ON/OFF the 
trip line display

Linear display or 
logarithmic display

Bar meter
Analog meter

Thermometer
Y-axis display

Axis type

Click a group tab to select the group.
Group Name
Click the Group Name box and enter the group name using up to 16 alphanumeric 
characters.

Channel
1.	 Click a channel cell. The Channel No. dialog box opens.

					   

4.2  Setting the Display Conditions
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2.	 Click the desired channel. The channel is selected and the dialog box closes.

	 To not assign a channel, click None at the bottom.

Showing/Hiding the Waveform
Select the No. check box.
Blue: Shows the waveform.
Gray: Hides the waveform.

Y-Axis
Set whether to show or hide the Y-Axis when multi-axis zone is selected. Click the check 
box.
Blue: Shows the Y-axis.
Gray: Hides the Y-axis.
Specifies the axis type. Linear and Log toggle each time the box is clicked.
Linear: Linear scale.
Log: Logarithmic scale.

Display
Set the display format for numeric values. Select floating-point (100.0) or exponential 
(1.000E2). Floating-point and exponential toggle each time the box is clicked.

Meter Type
Click one of the option buttons to select the type of meter to be displayed on the meter 
monitor from bar meter, analog meter, and thermometer.

Scale
Click the value box and enter the maximum and minimum values of the scale.
The range of values that can be entered is from -999999999 to 999999999 excluding the 
decimal point.
If you set the minimum value larger than the maximum value, the waveform is inverted.

Note
The decimal point position of the entered value is adjusted according to the number of 
significant digits to the right of the decimal point.

Zone
Click the value box and enter the maximum and minimum values of the waveform display 
zone. The range of values that can be entered is 0 to 99% for the minimum value and 1 
to 100% for the maximum value.

Trip 1 and Trip 2
Click the value box and enter the position of the trip line within the scale range. 
When you enter a value, the check box turns blue. If you do not wish to use the trip line, 
clear the check box.
Blue: Enable.
Gray: Disabled.

Note
Trip line 1 and 2 are displayed in red and blue, respectively.

4.2  Setting the Display Conditions
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Color
Set the waveform display color.

1.	 Click the Color box.

	 The Color dialog box opens.

					   

2.	 Click a color to select it. The Color dialog box closes.

Note
To create a new color, click Define Custom Colors. Use the palette that appears to create the 
new color.

4.2  Setting the Display Conditions
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4.3	 Changing the Waveform Display

This section describes how to change the display on the trend monitor screen and the 
circular monitor screen.

Changing the Time Axis
You can change the time axis display. On the absolute time display, the date is displayed 
at the left end.

Procedure
Choose Absolute Time or Relative Time from the Time-Axis menu.
Absolute Time:	Displays the time.
Relative Time: 	 Displays the elapsed time from the first data point.

Absolute time display

			 

Relative time display

			 

Zooming In or Out on the Time Axis
You can adjust the time span. The zoom factor of the time axis is displayed at the lower 
right corner.

Procedure
Click Zoom In or Zoom Out on the toolbar or choose Zoom In or Zoom Out from the 
Time-Axis menu.

		

Zoom In
Zoom Out

The waveform is displayed by zooming in or out of the time axis.

Note
•	 There are 14 zoom factors: 1/1000, 1/500, 1/200, 1/100, 1/50, 1/20, 1/10, 1/5, 1/2, 1, 2, 5, 

10, and 20.
	 However, the minimum zoom factor that can be displayed varies depending on the number 

of pixels in the waveform display area. Therefore, the minimum zoom factor that can be 
displayed varies depending on the monitor screen size.

•	 The absolute and relative time format (example: MM/DD HH:MM or HH:MM:SS) 
automatically switches depending on the zoom factor.

Selecting the Waveform Display Zone
You can change the display zone of the waveform.

Procedure
Click an icon for the waveform display zone on the toolbar or choose waveform display 
zone from the Y-Axis menu.

		  User Zone
Edit Zone

Multi-Axis Zone
Auto Zone

Full Zone Slide Zone
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•	 User Zone
	 Displays the waveform using the zone specified in the General Display Settings.

•	 Edit Zone
	 You can change the zone in the zone display area of the trend monitor screen.
	 In the zone display area, drag the slider at the top and bottom ends of the zone bar 

to change the zone. The zone setting specified in the zone display area is reflected in 
the General Display Settings dialog box.

			 
Zone bar

Top adjustment knob

Bottom adjustment knob

•	 Full Zone
	 Assigns a full zone to all the displayed waveforms.

			 

•	 Slide Zone
	 The zone width of each waveform is made equal, and the start position of the display 

zone is offset slightly for each waveform.

			 

•	 Auto Zone
	 Displays the waveforms by equally dividing the waveform display area according to 

the number of displayed waveforms.

			 

4.3  Changing the Waveform Display
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•	 Multi-Axis Zone
	 Displays the waveforms and multiple Y-axis (scale) in the zone specified in the 

General Display Settings.
	 When Data Monitor display updating is paused, you can add/delete the Y-axis by 

carrying out the following procedure.*

	 When adding a Y-axis:	 In the zone display area, drag the zone bar to be displayed 
to the waveform display area.

	 When deleting a Y-axis:	 In the waveform display area, drag the Y-axis to be deleted 
to the zone display area.

			 

Drag & drop the zone bar corresponding 
to the Y axis (scale) you wish to display.

Drag & drop the Y axis (scale) to be deleted.

Note
The waveform display area shows a grid that corresponds to the left-most Y-axis (scale). In 
addition, only the trip lines of the channels that have the left-most Y-axis are displayed.

4.3  Changing the Waveform Display
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Assigning Display Limits
You can specify how to display the waveform outside the display range.

Procedure
Click Clip on the toolbar or choose Clip from the Y-Axis menu.

		
Clip

The waveform display range along the Y-axis is limited to the minimum and maximum 
values of the scale specified in the General Display Settings. Measured data that 
is smaller than the scale (minimum) is displayed as a minimum value on the scale; 
measured data that is greater than the scale (maximum) is displayed as a maximum 
value on the scale.

	 •	 Display example when display limits are assigned on the displayed waveform

				  

	 •	 Display example when display limits are not assigned on the displayed waveform

				  

Turning ON/OFF the Waveform Display
To make a specific waveform stand out, you can hide other waveforms.

Procedure
Click the check box below the zone bar to turn ON (blue)/OFF the waveform display.

		

Grid brightness adjustment knob 
(see “Adjusting the Brightness”)

Brightness adjustment knob of the waveform display area 
(see “Adjusting the Brightness”)

Check box used to turn ON/OFF the waveform display

Zone bar

Specifying the Thickness of the Waveform Display Lines (Trend and Circular 
Monitor Screen)

Procedure
Choose Normal Line, Medium Line, or Thick Line from the View menu.

Adjusting the Brightness
You can adjust the brightness of the grid and background.

Procedure
Drag the grid brightness adjustment slider to change the grid brightness.
Drag the brightness adjustment slider of the waveform display area to change the are 
brightness.

4.3  Changing the Waveform Display
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Moving the Trip Line
You can move the trip line when display updating of Data Monitor is paused.

Procedure
1.	 Click Pause on the toolbar or choose Pause from the File menu.

	 The updating of the display on the monitor screen is paused.

2.	 Drag and drop the trip line to the desired position.

					   

Before dragging After dragging

Showing/Hiding Alarms
The alarm status is indicated at the bottom section of the waveform display area on the 
trend monitor.
When an alarm occurs, the time span during which alarm is activated is displayed using 
the waveform display color.
Level 1 to Level 4 alarms are shown in order from the top.
When multiple alarms occur simultaneously, the alarm corresponding to the current 
waveform (with a current waveform mark) is displayed on top.

		

No alarm

Alarm occurrence

Level 1
Level 2
Level 3
Level 4

Procedure
Click Alarm ON/OFF on the toolbar or choose Alarm from the View menu.
The alarms are shown or hidden.

		
Alarm ON/OFF

4.3  Changing the Waveform Display
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4.4	 Using Cursors

Cursors can be used on the trend monitor, color graph monitor, circular monitor, and 
alarm monitor.
•	 On the trend monitor, color graph monitor, and circular monitor, the measured data at 

the cursor position can be read out.
•	 On the alarm monitor, you can specify the alarm log using the cursor and read the 

measured data numerically at that point.
•	 When Link is turned ON, the cursor movement is reflected on the trend monitor, color 

graph monitor, circular monitor, and alarm monitor.
There are two cursors, cursor A and cursor B.
The Cursor’s Value dialog box displays the measured data numerically at the positions of 
cursor A and cursor B and the difference between the two.

Showing the Cursors and Reading the Values at the Cursor Positions
You can move the cursor when display updating of Data Monitor is paused.

Procedure
1.	 Click Pause on the toolbar or choose Pause from the File menu. The updating of 

the display on the monitor screen is paused.

					   
Pause

2.	 On the waveform display area, point to the position where measured data is to be 
read and drag the mouse to the other position. The first position is cursor A; the 
second position is cursor B.

					   

Cursor A Cursor B

3.	 Click Display Cursor’s Value on the toolbar or choose Display Cursor’s Value 
from the View menu.

					   
Display Cursor's Value
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	 The Cursor’s Value dialog box opens. The log date/time and values at the positions of 
cursor A and B are displayed.

	 To finely adjust the cursor position, click the cursor adjustment buttons to the right of 
the data number. Click once to move the cursor by one data point.

 	 When you move the cursor on the monitor screen, the result is reflected in the 
Cursor’s Value dialog box. This behavior is also true the other way around.

			 

Alarm indication (from the left: level 1, 2, 3, and 4)
Alarm occurring: Red
No alarm: Green

Cursor movement button

Displaying the Cursor Value from the Alarm Log Display
You can move the cursor when display updating of Data Monitor is paused.

Procedure
1.	 Click Pause on the toolbar or choose Pause from the File menu.

	 The updating of the display on the monitor screen is paused.

2.	 Click Display Cursor’s Value on the toolbar or choose Display Cursor’s Value 
from the View menu.

	 The Cursor’s Value dialog box opens.

4.4  Using Cursors
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3.	 On the Log page of the alarm monitor, point to an alarm log and drag the mouse 
to the alarm log. The first position is cursor A; the second position is cursor B.

	 The log time and values at the positions of cursor A and B are displayed in the 
Cursor’s Value dialog box.

					   
Display the values at the start and end points of the cursor selection area.

Clearing Cursors
Carry out the following procedure to clear the displayed cursors.
Cursors are also cleared when you resume the display updating.

Procedure
Choose Hide Cursor from the View menu.
When you clear the cursors, nothing is displayed on the Cursor’s Value dialog box.

4.4  Using Cursors
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4.5	 Saving the Connection Settings and Exiting 
the Monitor

Saving the Connection Settings
Connection settings refers to the display conditions of Data Monitor. If you save the 
connection settings before exiting Data Monitor, the condition is restored the next time 
Data Monitor is started.

Procedure
Select Save from the File menu. The connection settings are saved to AddTrigger 
installation folder\project name\folder.rmt).

Exiting Data Monitor
Procedure

Choose Exit from the File menu or click the X button at the upper right corner of the title 
bar.
Data Monitor closes.
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5.1	 Displaying Waveforms on Historical Viewer

Historical viewer displays the data that has been logged using waveforms or values.
You can start Historical Viewer from the Launcher or the Windows Start menu.

Starting Historical Viewer
Procedure

Start Historical Viewer using one of the following methods.
•	 Click Historical Viewer on the Launcher’s toolbar or choose Historical Viewer from 

the View menu.

			 

Historical Viewer

•	 From the Windows Start menu, choose Programs > YOKOGAWA DAQWORX > 
AddTrigger > Historical Viewer.

Note
If you started Historical Viewer from the Launcher, you can display data that is currently being 
logged. If you started Historical Viewer from the Windows Start menu, you cannot.

Historical viewer starts and the following screen appears.

Menu bar
Toolbar

Status bar

Chapter 5	 Displaying Logged Data (Historical Viewer)
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Opening Data Files
Procedure

1.	 Click Open on the toolbar or choose Open from the File menu.

Open

	 The Open dialog box appears.

					   

2.	 Select the desired file (the information about the selected file is displayed at the 
bottom section of the dialog box) and click Open. Waveforms are displayed.

Note
•	 Historical viewer can only display data that has been logged using AddTrigger. The 

extension is .mld.
•	 You can open multiple data files simultaneously. The number of data files that can be 

opened simultaneously varies depending on the memory size of the PC and the free disk 
space.

•	 If the file size is large (the number of data points that are logged is greater than or equal 
to 8 K and the size is 10 MB or more), the Select Option (file loading condition) dialog box 
appears for you to decide how to load the file’s contents.

					   

	 Select either of the following methods and click Select. The waveforms appear.
•	 When Read data as need (Minimum Memory) is selected
	 Displays the data so that the size of the used memory is minimized. The display speed is 

slower, but the size of the used memory can be minimized.
•	 When Read all data into memory (Fast Update) is selected
	 Displays the data by loading all the data into the memory. The amount of used memory is 

large, but the display speed is faster.

5.1  Displaying Waveforms on Historical Viewer
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3.	 Carry out the following procedure to switch between waveform display and 
numeric display.

•	 Click Waveform Display on the toolbar or choose Window > Waveform 
Display from the menu bar.

•	 Click Digital Value Display on the toolbar or choose Window > Digital Value 
Display from the menu bar.

Graph Sheet

Waveform Display Screen
Zoom In or Zoom Out of the time axis

Absolute or relative time

Waveform display 
ON/OFF

Zone bar
Active waveform 
mark

Alarm

General Display Settings

Copy

Drag this bar to widen or 
narrow the waveform display area.

Click this bar to show or hide 
the display zone display.

Brightness
adjustment knob 
of the waveform 
display area

Grid brightness 
adjustment knob

Zone display area
Open

Save Display 
Setting

Append Mark
Current data

Waveform display zone Clip
Graph (waveform display)

Sheet (numeric display)
Control (Display cursor's value)

Statistics

Print

About
Historical
Viewer

Launcher

Search

Overview spreader

Link previous file
Link next file

Alarm indication
(from the top: level 1, 2, 3, and 4)

Switch the grid density

Digital value display screen

Sheet (numeric display)
Graph (waveform display)

Trigger mark

Alarm indication (from the left: level 1, 2, 3, and 4)

Channel No., tag No., or tag comment

Append mark

Absolute/Relative time

5.1  Displaying Waveforms on Historical Viewer
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Data Overview
	 When set to waveform display, dragging the Overview spreader downward shows the 

Data Overview.
	 The Data Overview displays the measured data by assigning the following 50 colors in order.

	 Blue (minimum display scale), light blue, green, yellow, red (maximum display 
scale).

	 The waveforms in the section enclosed in the white frame on the Data Overview are 
displayed.

Overview spreader
Data overview

The parts enclosed in the white frame are displayed as waveforms.
Drag the frame to move the waveform display range.

Displaying the Waveforms That Are Currently Being Logged
You can display the data that is currently being logged. This operation is possible only 
when Historical Viewer is started from the Launcher.

Procedure
1.	 Click Current Data on the toolbar or choose Current Data from the View menu.

Current Data

	 The data file currently being logged is displayed.

Note
•	 Each time you click Current Data, the logging data up to that point is redisplayed.
•	 Do not display data being logged when starting the Historical Viewer from the PC's Start 

menu. Operation cannot be guaranteed. Data errors may occur.

5.1  Displaying Waveforms on Historical Viewer
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Viewing Information about the Loaded File
You can view the information about the data file in the active window.

Procedure
1.	 Choose About Document from the Information menu to display the File 

Information dialog box.

					   

2.	 You can enter or change the header for the data printout (Print Title in the above 
figure).

	 Click Print Title and enter the character string (up to 32 alphanumeric characters).

Note
•	 You can also enter or change the print title in the Printout Setup dialog box.
•	 When you enter or change the print title, the print title in the Printout Setup dialog box is 

changed accordingly.

Common Operations
Procedure

Arranging the Monitor Screens
Choose Tile or Cascade from the Window menu. The multiple monitor screens that are 
displayed are arranged accordingly.

Showing/Hiding the Toolbar or Status Bar
Choose Tool Bar or Status Bar from the View menu. A check mark appears next to or is 
cleared from the menu command and the relevant bar is shown/hidden.

Displaying the Launcher in Front
Click Launcher on the toolbar or choose Launcher from the View menu. The Launcher is 
displayed in front.

Launcher

Closing the Monitor Screen
Click the X button at the right end of the title bar. Or, activate the group screen you wish 
to close and choose Close from the File menu.
The message, “Save changes to xxx•” (where xxx is the file name) appears. Click Yes, 
No, or Cancel.
	 Yes: 			  Saves the display settings and closes the group screen.
	 No:			   Does not save the display settings and closes the group screen.
	 Cancel: 	 Cancels the operation of closing the group screen.

5.1  Displaying Waveforms on Historical Viewer
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5.2	 Setting the Display Conditions

You can specify the display conditions for each group.

Note
You can select a channel identifier of Channel No., Tag No., or Tag Comment. In the 
explanations below, the channel identifier is set to Channel, but you can substitute Tag No. or 
Tag Comment according to your situation.

Basic Operation
Procedure

Waveform number

A AB AD DCAC A D

Show or Hide

A to D are the collective setup buttons (see the next page).

Selecting the Waveform Number
•	 Click a waveform number in the No. column.
•	 To select waveform numbers consecutively, click the first waveform cell, and then click 

the last cell number while holding down the SHIFT key. You can also drag the cursor 
from the first waveform to the last.

Copying the Group Settings
Carry out the following procedure to copy the detailed settings of one group to another 
group.

1.	 Click Copy Setting in the General Display Settings dialog box.
	 The Copy Setting dialog box opens.

					   

2.	 Select the check boxes for the items to be copied and click OK. The dialog box 
closes.

3.	 Click the tab corresponding to the copy source group.
4.	 Click Copy.
5.	 Click the tab corresponding to the copy destination group.
6.	 Click Paste.
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Showing/Hiding the Waveform, Y-Axis, Trip 1, and Trip 2
•	 Click the waveform number, y-axis, trip 1, and trip 2 check boxes to switch between 

show (blue) and hide.
•	 If consecutive cells are selected, you can click the tool cell at the bottom to collectively 

switch the show/hide setting of all the cells in the selected range.
Using the Shortcut Buttons
There are four kinds of shortcut buttons.
You can enter a setting on every cell in the range all at once. If a range of waveform 
numbers is not selected, the action applies to all waveform numbers.
A: Shows or hides the selected items in the column.
B: Channel numbers are filled from the first cell in the selection to the last, each channel 

being assigned a number 1 higher than the last.
C: Copies the first value in the selected range to all items in the selected range.
D: Restores the default values.
Saving the Settings
Click OK to save the settings and close the General Display Settings dialog box.
Click Cancel to cancel the settings and close the General Display Settings dialog box.

Entering the Display Conditions for Each Group
Up to 32 channels can be assigned to a group. A maximum of 50 groups can be used.
The General Display Settings of Historical Viewer differ from that of Data Monitor in the 
following points.
•	 There is no Form item.
•	 There is no Meter Type item.
•	 There is no Apply button.
•	 There is a Scale Calc button.

Procedure
Click General Settings on the toolbar or choose View > General Settings from the menu 
bar. The Detailed Settings dialog box opens.

Color
Display range

Channels to be registered

Set the trip point

Show or Hide

Group name
Waveform display zone

Turn ON/OFF the trip line display
Y-axis display

Axis type

Group tab

Display type

5.2  Setting the Display Conditions
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Click a group tab to select the group.

Group Name
Click the Group Name box and enter the group name using up to 16 alphanumeric 
characters.

Tag Number
1.	 Click a tag number box. The Tag Number dialog box opens.

					   

2.	 Click the desired channel. The channel is selected and the dialog box closes.
	 To assign no channel, click None at the bottom.

Showing/Hiding the Waveform
Select the No. check box to change the setting.
	 Blue: 		  Shows the waveform.
	 Gray: 		  Hides the waveform.

Y-Axis
Set whether to show or hide the Y-Axis when multi-axis zone is selected. Click the check 
box. 
	 Blue: 		  Shows the Y-axis.
	 Gray: 		  Hides the Y-axis.
Specifies the axis type. Linear and Log toggle each time the box is clicked.
	 Linear: 		 Linear scale.
	 Log:			   Logarithmic scale.

Display Format
	 Select Floating point or Exponential display. Floating point and exponential toggle 

each time the display box is clicked.
	 : Floating point display
	 : Exponential display

Scale
Click the value box and enter the maximum and minimum values of the scale.
The range of values that can be entered is from -999999999 to 999999999 excluding the 
decimal point.
If you set the minimum value larger than the maximum value, the waveform is inverted.

Note
The decimal point position of the entered value is adjusted according to the number of 
significant digits to the right of the decimal point.

If you select a waveform number and click Scale Calc, the scale of the selected 
waveform number is set as follows:  
•	 Scale minimum = the minimum value of the logged data in the file
•	 Scale maximum = the maximum value of the logged data in the file

5.2  Setting the Display Conditions



5-9IM WX13-01E

D
isplaying Logged D

ata (H
istorical View

er)

1

2

3

4

5

Index

6

 
Zone
Click the value box and enter the maximum and minimum values of the waveform display 
zone. The range of values that can be entered is 0 to 99% for the minimum value and 1 
to 100% for the maximum value.

Trip 1 and Trip 2
Click the value box and enter the position of the trip line within the scale range.
When you enter a value, the check box turns blue. If you do not wish to use the trip line, 
clear the check box.
Blue: Enable.
Gray: Disabled.

Note
Trip line 1 and 2 are displayed in red and blue, respectively. 

Color
You can specify the waveform display color.

1.	 Click a Color box.

	 The Color dialog box opens.

					   

2.	 Click a color to select it. The Color dialog box closes.

Note
To create a new color, click Define Custom Colors. Use the palette that appears to create the 
new color.

5.2  Setting the Display Conditions



5-10 IM WX13-01E

5.3	 Changing the Waveform Display and Numerical 
Display

This section describes how to change the display on Historical Viewer screen.

Changing the Time Axis
You can change the time axis display. On the absolute time display, the date is displayed 
at the left end.

Procedure
Choose Absolute Time or Relative Time from the Time-Axis menu.
Absolute Time: 	Displays the time.
Relative Time: 	 Displays the elapsed time from the first data point.

	 Absolute time display

			 

	 Relative time display

			 

Zooming In or Out on the Time Axis
You can adjust the time span. The zoom factor of the time axis is displayed at the lower 
right corner.

Procedure
Click Zoom In or Zoom Out on the toolbar or choose Zoom In or Zoom Out from the 
Time-Axis menu.

Zoom In
Zoom Out

The waveform is displayed after zooming in or out of the time axis.

Note
•	 There are 14 zoom factors: 1/1000, 1/500, 1/200, 1/100, 1/50, 1/20, 1/10, 1/5, 1/2, 1, 2, 5, 

10, and 20.
	 However, the minimum zoom factor that can be displayed varies depending on the number 

of pixels in the waveform display area. Therefore, the minimum zoom factor that can be 
displayed varies depending on the monitor screen size.

•	 The absolute and relative time format (example: MM/DD HH:MM or HH:MM:SS) 
automatically switches depending on the zoom factor.

Choose Time-Axis > Scale from the menu bar to open the Time Axis Scale dialog box.
You can expand or reduce the time axis at an arbitrary factor that you enter.
•	 Zoom in range: 1 to 20 (whole number)
•	 Zoom out range: 1/1 to 1/1000 (the denominator is a whole number)

Choose All from the Time-Axis menu to adjust the zoom factor so that all the data can be 
displayed on the waveform display screen.
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Selecting the Waveform Display Zone

You can change the display zone of the waveform.

Procedure
Click an icon for the waveform display zone on the toolbar or choose Waveform display 
zone from the Y-Axis menu.

		  User Zone
Edit Zone

Multi-Axis Zone
Auto Zone

Full Zone Slide Zone

•	 User Zone
	 Displays the waveform using the zone specified in the General Display Settings.

•	 Edit Zone
	 You can change the zone in the zone display area of the graph screen.
	 In the zone display area, drag the slider at the top and bottom ends of the zone bar 

to change the zone. The zone setting specified in the zone display area is reflected in 
the General Display Settings dialog box.

	 Drag the top adjustment slider to move the top end of the zone.
	 Likewise, drag the bottom adjustment slider to move the bottom end of the zone.
	 The entire zone moves by dragging the zone bar itself.

			 
Zone bar

Top adjustment knob

Bottom adjustment knob

•	 Full Zone
	 Assigns a full zone to all the displayed waveforms.

			 

5.3  Changing the Waveform Display and Numerical Display
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•	 Slide Zone
	 The zone width of each waveform is made equal, and the start position of the display 

zone is offset slightly for each waveform.

			 

•	 Auto Zone
	 Displays the waveforms by equally dividing the waveform display area according to 

the number of displayed waveforms.

			 

	
•	 Multi-Axis Zone
	 Displays the waveforms and multiple Y-axis (scale) in the zone specified in the 

General Display Settings.
	 You can add/delete the Y-axis by carrying out the following procedure.

	 When adding a Y-axis: 	 In the zone display area, drag the zone bar to be displayed 
in the waveform display area.

	 When deleting a Y-axis: 	 In the waveform display area, drag the Y-axis to be deleted 
and drop it in the zone display area.

			 

Drag & drop the zone bar corresponding to the 
Y axis (scale) of the channel you wish to display

Drag & drop the Y axis (scale) to be deleted

Note
The waveform display area shows a grid that corresponds to the right-most Y-axis (scale). In 
addition, only the trip lines of the channels that have the right-most Y-axis are displayed.

5.3  Changing the Waveform Display and Numerical Display
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Assigning Display Limits
You can specify how to display the waveform outside the display range.

Procedure
Click Clip on the toolbar or choose Clip from the Y-Axis menu.

		
Clip

The waveform display range along the Y-axis is limited to the minimum and maximum 
values of the scale specified in the General Display Settings. Measured data that 
is smaller than the scale (minimum) is displayed as a minimum value on the scale; 
measured data that is greater than the scale (maximum) is displayed as a maximum 
value on the scale.

•	 Display example when display limits are assigned on the displayed waveform

				  

•	 Display example when display limits are not assigned on the displayed waveform

				  

Turning ON/OFF the Waveform Display
To make a specific waveform stand out, you can hide other waveforms.

Procedure
Click the check box below the zone bar to turn ON (blue)/OFF the waveform display.

		

Grid brightness adjustment knob 
(see “Adjusting the Brightness”)

Brightness adjustment knob of the waveform display area 
(see “Adjusting the Brightness”)

Zone bar

Check box used to turn ON/OFF the waveform display

5.3  Changing the Waveform Display and Numerical Display
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Adjusting the Brightness
You can adjust the brightness of the grid and background.

Procedure
Drag the grid brightness adjustment slider to change the grid brightness.
Drag the brightness adjustment slider of the waveform display area to change the area’s 
brightness.

Moving the Trip Line
Procedure

Drag and drop the trip line to the desired position.

		

Before dragging After dragging

Showing/Hiding Alarms
Procedure

Click Show/Hide Alarms on the toolbar or choose Alarm from the View menu.

		
Alarm

Alarm indication appears on the Waveform screen, Digital Value screen, and the Cursor’s 
Value dialog box.
However, if there is no alarm data in the loaded data file, alarms are not displayed.

•	 Waveform (Graph) Display Screen
	 The time span during which an alarm is activated is displayed using the waveform 

display color. Level 1 to Level 4 alarms are shown in order from the top. When multiple 
alarms occur simultaneously, the alarm corresponding to the active waveform (with an 
active mark) is displayed on top.

			 

Alarm indication

Level 1
Level 2
Level 3
Level 4

5.3  Changing the Waveform Display and Numerical Display
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•	 Numerical Value Display Screen

Alarm indication (from the left: level 1, 2, 3, and 4)
Alarm occurring: red, no alarm: green

•	 Cursor’s Value Dialog Box

			 

Alarm indication (from the left: level 1, 2, 3, and 4)
Alarm occurring: red, no alarm: green

Note
•	 When the alarm display is turned ON/OFF on one of the screens above, the alarm display 

on the other two screens is also changed.
•	 When there is no alarm data in the loaded data file, Alarm on the View menu is unavailable.

Changing the Grid Display
Procedure

Select the grid type by clicking Grid density on the toolbar, or Y-axis on the menu bar.
Switch the grid density.

Switch the grid density

5.3  Changing the Waveform Display and Numerical Display
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5.4	 Using Cursors

On the Graph screen, the measured data at the cursor position can be read. There are 
two cursors, cursor A and cursor B.
The Cursor’s Value dialog box displays the measured data numerically at the positions of 
cursor A and cursor B and the difference between the two.
You can specify an area using cursor A and cursor B and display the maximum value, 
minimum value, P-P value, average value, and rms value of the measured data in the 
area.

Showing the Cursors and Reading the Values at the Cursor Positions
Procedure

1.	 In the waveform display area, point to the position where measured data is to be 
read and drag the mouse to the other position. The first position is cursor A; the 
second position is cursor B.

					   

Cursor A Cursor B

2.	 Click Cursor’s Value on the toolbar.

					   
Control (Display Cursor’s Value)

	 The Cursor’s Value dialog box opens. The log date/time and values at the 
positions of cursor A and B are displayed.

	 To finely adjust the cursor position, click the cursor adjustment buttons to the right 
of the data number. Click once to move the cursor by one data point.

 	 The cursor operation and display apply to the Graph screen, Sheet screen, and 
Control dialog box.

					   

Cursor movement button
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Clearing Cursors
Carry out the following procedure to clear the displayed cursors.

Procedure
Choose Hide Cursor from the View menu.
When you clear the cursors, nothing is displayed in the Cursor’s Value dialog box.

Copying the Data between the Cursors to the Clipboard
You can copy the data in the range specified Using Cursors to the clipboard for use in 
other applications.

Procedure
1.	 On the Graph screen or Sheet screen, drag the mouse to select the range (up to 

1000 points) you wish to copy to the clipboard.

2.	 Click Copy on the toolbar or choose Copy from the Edit menu.

	 The data in the selected range is copied to the Windows clipboard.

	 Copy

					   
Copy

3.	 Data that has been copied to the clipboard can be pasted in other applications for 
use.

• 	 Example of copying to the clipboard

			 

Note
•	 You can copy up to 1000 data points to the clipboard. 
•	 When the display mode of the time axis is set to Absolute Time, the absolute time is output. 

5.4  Using Cursors
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Displaying Statistical Computation Results over an Area
You can specify an area using cursor A and cursor B and display the maximum value, 
minimum value, P-P value, average value, and rms value of the measured data in the 
area.

Procedure 
1.	 Specify the computation area by dragging the mouse on the Graph screen or 

Sheet screen.

2.	 Click Area Calculation on the toolbar or choose Display Calculation Results 
from the Window menu.

					   
Statistics

	 The Calculation Results dialog box shows the computed result.

					   

Data range to be computed (data No.)

Note
•	 If you change the computation area, carry out the above procedure again.
•	 If a computation area is not specified Using Cursors, the computation is performed over the 

entire area of the data file.
•	 The Statistics dialog box shows the computed results of the data displayed on the active 

viewer screen.
•	 The rms value is computed using the following equation.

				  

1
n

(x  )2
Σ
k=0

n-1
 k 

k

rms =

n  : Number of data
x : Value

5.4  Using Cursors
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5.5	 Using Marks

Marks can be placed at the positions specified with the cursor.
By default, the following marks are placed.
•	 TRIG: Data at the logging start point (first data of the file)
•	 BOUNDARY: Data at the division point when the logged data is stored to divided 

files (first data point of files after the 1st file) and the first data point of the file that is 
created by data exporting (see section 5.9).

Placing Marks
Procedure

1.	 On the Graph screen, click the position where a mark is to be placed. Or, on the 
Sheet screen, click the Date [No] box where a mark is to be placed.

	 One cursor is displayed.

2.	 Click Append Mark on the toolbar or choose Append Mark from the Edit menu.

	 The Mark Setting dialog box opens.

					   
Append Mark

	 Append mark

3.	 Click the option button to select the group on which a mark is to be placed.

	 All Groups:	  Places marks on all groups.

	 Current Group:	  Places a mark on the displayed group.

Note
Make this selection when you create groups on Historical Viewer.

4.	 Click the text box and enter the character string (up to 16 alphanumeric 
characters).

					   

5.	 Click OK.

	 A mark is displayed at the cursor position.

Note
•	 To change the mark character string, double-click the mark. The Mark Setting dialog box 

opens.
•	 If two cursors are displayed, you cannot place marks.
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Deleting Marks
Procedure

1.	 Place cursor A and cursor B so that the marks to be deleted are in between the 
cursors.

2.	 Choose Delete Mark from the Edit menu.

	 The marks between cursor A and cursor B are deleted.

Setting the Marks to the Default Condition (Clearing All Marks Except TRIG and 
BOUNDARY)

Procedure
	 Choose Reset Mark from the Edit menu. All the added marks are deleted. 

5.5  Using Marks
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5.6	 Searching for Measured Data, Alarms, and 
Marks

You can set search conditions and search for measured data, alarms, and marks. When 
the measured data, alarm, or mark is found, the cursor is displayed at that position.

Procedure
1.	 Select the search range Using Cursors.
2.	 Click Search on the toolbar or choose Edit > Search from the menu bar.

Search settings

	 The Search dialog box opens.

					   

Group selection button

Channel selection button

3.	 Select OR or AND logic for the two conditions specified in steps 4 to 8.
	 Click the list box and choose either one.
	 OR: 	 Search items where either condition is met.
	 AND: 	 Search items where both conditions are met.

	 Repeat steps 4 to 8 to set conditions 1 and 2.
4.	 Click the list box and select the search type.
	 None: 	 Set no conditions.
	 Data: 	� Search for special data (LACK, +OVER, -OVER, and OFF) (see the next 

page).
	 Mark: 	 Search for marks.
	 Alarm: 	 Search for alarms
	 Value: 	 Search for measured values

	 When Searching for Special Data
5.	 Select the groups to be searched.
	 Click the group selection button to display the Group selection dialog box. Click a 

group name. Click ALL to select all groups for searching.
	 The selected groups are displayed on the group selection button.

Note
Make this selection when you create groups on Historical Viewer.
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6.	 Select the channels to be searched.

	 Click the channel selection button. The Tag Number dialog box displays the 
channels that are contained in the group. Click a channel. Click ALL to select all 
the channels in the group to be searched.

	 The selected channels are displayed on the channel selection button.

					   

7.	 Click the list box and select the type of data to be searched.

	 LACK: 	 Search for data dropouts.

	 +OVER: Search for data that is over the upper limit of the measurement range.

	 –OVER: 	Search for data that is below the lower limit of the measurement range.

	 OFF: Search for OFF data.*
*	 OFF data refers to data that indicates the condition in which the communication to the 

recorder is disconnected and in which the data logging software cannot scan and record 
the data from the recorder.

When Searching for Marks
5.	 Select the groups to be searched.
	 The operating procedure is the same as that in “When Searching Special Data.”  
6.	 Enter a search string.
	 AddTrigger searches for marks containing the specified string in their names. The 

search is not case-sensitive. If you enter only an asterisk, AddTrigger searches for 
all marks.

When Searching Alarms
5.	 Select the groups to be searched.
	 The operating procedure is the same as that in “When Searching for Special 

Data.”
6.	 Select the channels to be searched.
	 The operating procedure is the same as that in “When Searching for Special 

Data.”
7.	 Select the alarm type.
	 Click the list box and select the alarm type.
	 Alarm All: Search for all alarms.
	 Alarm 1, Alarm 2, Alarm 3, or Alarm 4:	� Search for the specified Alarm No. 

(alarm level).
8.	 Set the alarm condition to be searched.
	 Click the list box and select the alarm status.
	 Changed:Data position where the alarm changed from ON to OFF or OFF to ON.
	 Start: 	 Data position where the alarm ON status started.
	 End: 	� Data position where the alarm ON status ended (data position 

immediately before the alarm turned OFF).

5.6  Searching for Measured Data, Alarms, and Marks
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	 ON: 	 Data position where the alarm is ON.

	 OFF: 	 Data position where the alarm is OFF.

When Searching for Measured Data
5.	 Select the groups to be searched.

	 The operating procedure is the same as that in “When Searching for Special 
Data.”

6.	 Select the channels to be searched.

	 The operating procedure is the same as that in “When Searching for Special 
Data.”

7.	 Set the type of comparison. The reference value is set in step 8.

	 Select the type of comparison from the list box.

	 ==: Search for data that are equal to the reference value.

	 >: Search for data that are greater than the reference value.

	 <: Search for data that are less than the reference value.

	 >=: Search for data that are greater than or equal to the reference value.

	 <=: Search for data that are less than or equal to the reference value.

	 !=: Search for data that are not equal to the reference value.

8.	 Set the reference value.

	 Click the box and enter the value.

	 The range of values is from -9999999999 to 9999999999. You can also use 
exponential notation (for example, 32E+5).

Search Direction
9.	 Select the Opposite (reverse direction) or Sequence (forward direction) option 

button. The search direction depends on the number of cursors that are displayed 
and the Opposite or Sequence setting as follows:

Number of Cursors Displayed Opposite/Sequence Search Direction
None Sequence From the first data point to the last data point

Opposite From the first data point to the last data point

1 Sequence From the cursor position to the last data point
(A and B are at the same position) Opposite From the cursor position to the last data point
2 Sequence From cursor A to cursor B
(A is in front of B on the time axis) Opposite From cursor B to cursor A

10.	Specify the cursor to be displayed at the data position that matched the search 
conditions. You can specify Cursor A, Cursor B, or Cursor A and B.

11.	 Click Run to execute the search, and the cursor is displayed at the data position 
that matched the search conditions. The search result (group number, waveform 
number, and data number) is displayed at the bottom section of the dialog box.

12.	If you click Run again, the cursor is displayed at the next data position that 
matched the search conditions, and the search result is displayed at the bottom 
section of the dialog box.

	 If there are no data that match the search conditions, Not Found is displayed at 
the bottom section of the dialog box.

13.	Click Close to close the Search dialog box.

5.6  Searching for Measured Data, Alarms, and Marks
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Example of an Alarm Search
This section explains the procedure for searching for the point of change of alarm level 1 
of channel TAG0005 in the range specified by the cursors.

1.	 Display the waveform and specify a range Using Cursors.

2.	 Click Search on the toolbar. The Search dialog box opens.

3.	 Set the search conditions as follows.

	 OR/AND:	You do not have to change this, because only one condition will be 
specified.

	 Search Type: Alarm:

	 Group: You do not have to change this (leave as ALL)

	 Tag: TAG0005

	 Alarm Level: Alarm 1

	 Alarm Condition: Point of Change

	 2nd Condition: None

4.	 Set the search direction equal to the progression of time.

	 Click the Sequence option button.

5.	 Display cursor A at the search result.

	 Cursor: Select the cursor A check box.

6.	 Click Run to execute the search. Cursor A is displayed at the data position where 
the alarm changed. Data can be read in from the cursor’s value display.

7 .	 Click Run to execute the search again. Cursor A is displayed at the next data 
position where the alarm (that matches the conditions) changed.

The first search result
(cursor A)

Position of cursor A when the search range 
is specified (The dotted line is not displayed)

Position of cursor B

Alarm 1

Click "Run" to move cursor A to 
the next point of the search result.Waveform of TAG0005

5.6  Searching for Measured Data, Alarms, and Marks
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5.7	 Linking and Displaying Data Files

File Link and Display Function
Data files that are continuous in time can be linked and displayed. Historical viewer can 
handle data files that have been saved to divided files as a single file.

Data files that are continuous in time

		

Reference time range

Time flow

: Files containing data that does not overlap with the reference time range 
 and is continuous with the reference time range.
: Files containing data that overlaps with the reference time range and 
 data in the time range before, after, or both.
 (Files that are continuous in time must be data files that are created in a 
 single session of logging start and logging end.  Even if the above 
 conditions are met, data files that were created during different logging 
 start and logging end operations are not files that are continuous in time.)

: Files that are not continuous with the reference time range
: Files that are contained in the reference time range

Files that are continuous in time
• (1), (4)

• (2), (3), (5)

(1)

(2)

(3)

(4)

(5)

(6) (7)(8)

Files that are discontinuous in time
• (6), (7)
• (8)

Linking Previous Files
You can search for files containing data that are continuous in time and that are before 
the time range that is currently displayed ((3), (4), and (5) in the above figure), and link 
the appropriate data file. The files are searched for within the same directory as the data 
file that is currently loaded and displayed.

Procedure
1.	 Click Link previous file on the toolbar or choose Link Previous File from the File 

menu. Data files that can be linked are searched.

Link previous file

2.	 The following three operations are executed depending on the search result.
	 •	 If a file that can be linked does not exist, linking is not performed, and Link 

Previous File in the File menu and the toolbar button becomes unavailable.
	 •	 If a single file that can be linked is found, the file is automatically linked.
	 •	 If multiple files that can be linked are found, the Previous Linkable Files 

dialog box appears. A list of linkable files is displayed with the start and 
end times. When linking previous files, the files are displayed in order from 
those with the oldest start time. Click the name of the file you wish to link to 
perform the link.
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3.	 When the name of the file you wish to link is selected, the Select Option dialog 
box may appear. Select either process, and click Select to perform the link.

Note
•	 The Select Option dialog box appears when adding the selected file causes the number of 

displayed data points to be 8 KB or more and the load size to be 10 MB or more. For details, 
see “Opening Data Files” in section 5.1.

•	 When data files are linked, the extension of the data file name that is displayed on the title 
bar changes from .mld to .lml (If the extension is already .lml, it is not changed).

Linking Succeeding Files
You can search for a data file that is continuous in time that is after the time range that 
is currently displayed ((1), (2), and (3) in the figure on the previous page), and link the 
appropriate data file. The files are searched for within the same directory as the data file 
that is currently loaded and displayed.

Procedure
1.	 Click Link next file on the toolbar or choose Link Next File from the File menu. 

Data files that can be linked are searched.

Link next file

2.	 The following three operations are executed depending on the search result.

	 •	� If a file that can be linked does not exist, linking is not performed, 
and Link Next File in the File menu and the toolbar button becomes 
unavailable.

	 •	 If a single file that can be linked is found, the file is automatically linked 

	 •	� If multiple files that can be linked are found, the Next Linkable Files 
dialog box appears. A list of linkable files is displayed with the start and 
end times. When linking succeeding files, the files are displayed in order 
from those with the oldest start time. Click the name of the file you wish 
to link to perform the link.

							     

3.	 When the name of the file you wish to link is selected, a Select Option dialog box 
may appear. For details, see “Linking Previous Files” in the previous section.

5.7  Linking and Displaying Data Files
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Displaying a List of Linked Files
	 You can display a list of linked files and check the link condition of the current file.

Procedure
	 Select Link Files from the Window menu. The Link Files dialog box appears.

			 

	 The displayed information consists of File, Start, and End. The list is displayed in order 
from the oldest start time.

5.7  Linking and Displaying Data Files
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5.8	 Converting the Data Format

You can convert data files to ASCII, Lotus, or Excel data format.
The names of the converted files are as follows:
•	 Converted to ASCII: original file name.txt
•	 Converted to Excel: original file name.xls
	 The file can be opened on Excel version 4.0 or later.
•	 Converted to Lotus: original file name.wj2
	 The file can be opened on Lotus1-2-3 version 2.0 or later.

Procedure
1.	 Choose To ASCII, To Lotus, or To Excel from the Convert menu.
	 The conversion dialog box appears.
2.	 Enter the range of data to be converted (data number for starting the conversion* 

and data number for ending the conversion*). The logging time is displayed to the 
right of the text box.
*	 The data number is numbered from 0 from the first data point in the file.

3.	 Enter the step number (Step).
	 To convert all the data in the specified range, set the step number (Step) to 1.

					   

3.	 To specify the data to be converted using groups, click the Group option button to 
enter the group number in the text box.

	 To specify the data to be converted using channel numbers, click the Tag option 
button to press the channel number button.

	 A dialog box used to select the channel number appears. Click the desired 
channel number.

4.	 To change the destination folder or the name of the file containing the converted 
data, click the File button.

	 The Change the file name dialog box appears.
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5.	 Select the destination and the file type and enter the file name.

6.	 Click OK.
			   The measured data is converted to the selected data format and saved to the file.

File Conversion Format of Logged Data
The Lotus 1-2-3, Excel, and ASCII file formats are indicated below.
	 Lotus 1-2-3 and Excel File Format

			 

	 ASCII File Format
Title CR LF
Date and time the first data point was logged CR LF
Date and time the last data point was logged CR LF
Data acquisition interval CR LF
Data count CR LF
Group CR LF
Comment (eight lines) CR LF
Channel CR LF
Tag No. CR LF
Tag comment CR LF
Unit CR LF
Date format CR LF
Time when the data was measured and the CR LF
measured data
(Repeat the number of data points)

5.8  Converting the Data Format
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•	 Title

			 

1

“

2

A

3

d

4

d

5

T

6

r

7

i

8

g

9

g e r

10 11 12 13

( R

14 15

.X

16

X

17

X

18

)

19 20

21 22 23 24

o

25

f

26

t

27

w

28

a

29

r

30

 e

31 32

I

33

D

34 35

x

36

x

37

x

38

-

39

x

40

x x

41 42

x

43 44

x

45

RX.XX is the software revision number.  SoftwareID is the license number.  

S

” CR LF

•	 Date and time the first data point was logged

			 

1

"

2

S

3

t

4

a

5

r

6

t

7 8

T

9

I

10

m

11

e

12

"

"

13

,

14

"

15

2

16

0

17

0

18

2

19

/

20

0

21

3

22

/

23

3

24

1

25 26

,

27

"

28

0

29

1

30

:

31

0

32

2

33

:

34

0

35

0

36

.

37

5

38

0

39

0

40

"

41

CR

42

LF

•	 Date and time the last data point was logged

			 

1

"

2

E

3

n

4

d

5 6 7 8

T

9

i

10

m

11

e

12

"

13

,

14

"

15

2

16

0

17

0

18

2

19

/

20

0

21

3

22

/

23

3

24

1 "

25 26

,

27

"

28

2

29

3

30

:

31

5

32

9

33

:

34

5

35

9

36

.

37

0

38

0

39

0

40

"

41

CR

42

LF

•	 Data acquisition interval

			 

1

"

2

S

3

a

4

m

5

p

6

l

7

e

8 9

R

10

a

11

t

12

e

13 14

(

15

S

16

e

17

c

18

)

19

"

20

,

21

Data acquisition interval example (top section: 0.5 s, bottom section: 60 s)

22 23 24 25 26 27 28

Data acquisition interval

29 30 31

LFCR

21 22 23 24 25 26 27 28 29

005.0

000.06

5.8  Converting the Data Format
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•	 Data count

			 

1

"

2

D

3

a

4

t

5

a

6 7

C

8

o

9

u

10

n

11

t

12

"

13

 ,

14

Data count

15 16 17 18 19 20

21

Data count example (top section: 100 points, bottom section: 120000 points)

22 23 24

LFCR

15 16 17 18 19

1

20 21

0

22

0

1 2 0 0 0 0

•	 Group

			 

1

If you converted the data by specifying groups, the range of groups is displayed.
If you converted the data by specifying channels (tags), spaces are inserted for the group range.

"

2

G

3

r

4

o

5

u

6

p

7

"

8

,

9

"

10

0

11

2

12

-

13

1

14

0

15

"

•	 Comment 

			 

1

"

2 3 4 5 6

. . .

7 8 9 10 11 12 13

C o m m e n t 1 " , "

14

Title 16 characters

Comment 64 characters

. .

.

. 29

. . 96

30

97

"

31

32

"

33

" ,

Example when the comment number is 1

•	 Channel

			 

1

"

2

C

3

H

4

.

5 6

N

7

o

8

.

9

" " ,

" " ,

?

?

The length occupied by a single channel varies depending on the length of the character string.  
Each channel is enclosed in quotations.  Thus, the length occupied by a single channel is 
"the length of the channel character string + 2."

Channel example (when the first channels is "CH0001" and the second channel is "CH0002")

. . . . . . . ?

. . . . .

..

.

. . . . .

. . .

?

CR

?

LF

9

"

10

C

11

H

12

0 0

13 14

0

15

1

16 17 18 19 20 21 22 23 24

" ", 0 0 0 2 " ,

Channel 1

Channel 2

•	 Tag no.

			 

1

"

2

T

3

a

4

g

5 6

N

7

o

8

.

9

" Tag No. 1 " ,

" " ,

?

?

The length occupied by a single tag No. varies depending on the length of the character string.  
Each tag No. is enclosed in quotations.
Thus, the length occupied by a single tag No. is "the length of the tag No. + 2."

Tag No. example (when the first tag No. is "TAGNO01" and the second tag No. is "002")

. . . . . . . ?

. . . . .

..

.

. . . . .

. . .

?

CR

?

LF

9

"

10

T

11

A

12

G N

13 14

O

15

0

16 17 18 19 20 21 22 23 24

1 ," " 0 0 2 " ,

Tag No. 2

5.8  Converting the Data Format
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•	 Tag comment

			 

1

"

2

T

3

a

4

g

5 6

C

7

o

8

m

9 10 11 12 13 14

m e n t " ,

15 ?

" " ,

The length occupied by a tag comment varies depending on the length of the character string.  
Each tag comment is enclosed in quotations.
Thus, the length occupied by a single tag comment is "the length of the tag comment + 2."

Tag comment example (when the first tag comment is "TAG0001" and the second tag comment is 
"0002")

15

"

16

T

17

A

18

G 0

19 20

0

21

0

22 23 24 25 26 27 28 29 30 31 32

1 ," " 0 0 0 2 " , "

. . . .

" Tag comment 2 " ,

? . . . . . . . ?

. . . . .. . . .

?

CR

?

LF

Tag comment 1

•	 Units

			 

1

"

2

U

3

n

4

i t

5 6

"

7

,

8

"

?

Unit 1 " " Unit 2 ",

The length occupied by a single unit varies depending on the length of the character string.  
Each unit is enclosed in quotations.
Thus, the length occupied by a single unit is "the length of the unit + 2."

Unit example (when the first unit is "V" and the second unit is "mV")

8

"

9

V

10

"

11

, "

12 13

m

14

V

15 16 17

" ",

. . . . . . . . .

,

?

. . . . . . . .

?

CR

?

LF

•	 Date Format

			 

1

"

2

Y

3

Y

4

Y

5

Y

6

/ M M / D D

7 8 9 10 11 12 13 14 15

H H : m m : SS

16 17 18 19 20

1

"

2

D

3

D

4

D

5 6

H H : m m :

7 8 9 10 11 12 13 14 15 17 18

S S . S S S "

16

For relative time

For absolute time

21 22

. S

23

S

24

S

25

"
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•	 Time Data Was Measured and the Measured Data

			 

1

"

2

Y

3

Y

4

Y

5

Y

6

- M M - D D

7 8 9 10 11 12 13 14 15

H H : m m : SS

16 17 18 19 20

21

.

22

S

23

S

24

S " ,

25 26

Measured value 1

27 28 29 30 31 32 33 34 35

, Measured value 2

36 37 38 39 40

1

"

2

2

3

0

4

0

5

2

6

/ 0 3 / 3 1

7 8 9 10 11 12 13 14 15

1 0 : 3 0 : 01

16 17 18 19 20

21

.

22

5

23

0

24

0

25

"

26

,

41 42 43 44 45 46

, . . . . . . . . . . . . LFCR

? ?

1

"

2

D

3

D

4

D

5 6

H H : m m :

7 8 9 10 11 12 13 14 15

S S . S S S " ,

16 17 18 19 20

21 22

Value

23 24 25 26

Value

27 28 29 30 31 32 33 34 35 36 37 38 39 40

41 42 43 44 45 46 47 48

, . . . . . . . . . LFCR

? ?

For relative time

1

"

2

0

3

0

4

3

5 6

1 0 : 3 0 :

7 8 9 10 11 12 13 14 15

1 0 . 5 0

16 17

0 "

18

Relative time example (for 10:30:10.5 on the third day)

(1) (2) (3) (4) (5)

1

(6)

0 . 1 2 ,

(7) (8) (9) (10)

1 2 0 0 . 0 ,

Measured data example (top section: 10.12, bottom section: 1200.0)

For absolute time

The length occupied by an absolute time is fixed to 25 characters.
The length occupied by a relative time is fixed to 18 characters.
The length occupied by a single measured value is fixed to 9 characters.

Absolute time example (for 10:30:10.5 on March 31, 2002)

Value

,,

5.8  Converting the Data Format
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5.9	 Exporting Data

You can extract (copy) a section of a data file and save the result. This operation does 
not change the original data.

Procedure
1.	 Select the range of data to be extracted by using cursors.

2.	 Choose Export from the Convert menu.

	 The Export dialog box opens.

					   

3.	 The range that was selected by the cursors is indicated in the Start and End 
boxes using data numbers. The logging time is displayed to the right of the text 
box.

	 To change the data range to be exported, enter values in the appropriate boxes.

4.	 Click File to open the Change the file name dialog box. Change the file name and 
destination as necessary and click OK.

Note
The default file name is as follows:
Original file name-first data number (8 digits) of the range to be exported.mld.

5.	 Click OK to create the file and close the dialog box. Click Cancel to close the 
dialog box without creating the file.



5-35IM WX13-01E

D
isplaying Logged D

ata (H
istorical View

er)

1

2

3

4

5

Index

6

5.10	 Printing the Data

You can print out the measured data that is displayed on Historical Viewer.

Selecting the Printer  
You can specify the printer used to print the data.
The printer setup operation is the same as that of the standard Windows print command.

Procedure
1.	 Choose Print Setup from the File menu.

	 The Print Setup dialog box opens.

2.	 Change the items in the dialog box as needed, and then click OK.

Note
Enter printer settings according to the environment of the system that you are using.

Previewing the Printout
Procedure

1.	 Select Print Preview from the File menu.

	 The Printout Setup dialog box opens.

2.	 Specify the print range and other information.
For graphs, click the option button to set the range and color. Enter a print title if 
desired.

					   

For sheets, specify the print range.

					   

3.	 Click OK.

	 The print preview window is displayed.

Note
For the print preview operation, see the instruction manual that came with your operating 
system.
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Printing the Data
Procedure

1.	 Click Print on the toolbar or choose Print from the File menu.

Print

2.	 Specify the print range and other information.
For graphs, click the option button to set the range and color. Enter a print title if 
desired.

					   

For sheets, specify the print range.

					   

3.	 Click OK.

	 The Print dialog box opens.

					   

4.	 Select the printer name and number of copies, and click OK.

	 Printing starts.

Note
The print range on the Print dialog box is void. The range specified on the Printout Setup dialog 
box is used.

5.10  Printing the Data
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5.11	 Saving the Display Settings, Saving the Link 
Settings, and Exiting Historical Viewer

When exiting Historical Viewer, the display settings can be saved. The next time 
Historical Viewer is started the display settings are restored.
You can also save the display settings by choosing Save Display Setting from the 
File menu. When multiple data files are linked and displayed using the file link display 
function described in section 5.7, the display settings at that point are saved, and the link 
settings are saved as a link file. If the link file is loaded the next time Historical Viewer is 
started, the link settings are also restored and displayed.

The information that is saved to the display settings file is as follows:
•	 Print title
•	 Cursor A and Cursor B positions
•	 ON/OFF condition of the waveform display limiter
•	 Settings specified in the general display settings
•	 Mark information
•	 Zoom factor of the time axis
•	 Display mode of the time axis (absolute/relative)
•	 Waveform display area
•	 The background and grid color of the waveform display area
•	 Y-axis zone setting
•	 The active waveform
•	 Selected group
•	 ON/OFF condition of the alarm display
•	 Displayed channel identifier (channel, tag number, or tag comment)
•	 Group name
•	 Grid density

Saving the Display Settings
You can save the display settings of the data file. The display conditions are saved to 
a file with the .dml extension in the same folder as the data file. When multiple files are 
linked, the link status is saved to the link file (.lml extension) in addition to the display 
settings.

Procedure
Click Save Display Setting on the toolbar or choose Save Display Setting from the File 
menu. The display settings are saved.

Save Display Setting

Saving the Display Settings and Link Settings
Save the link file by specifying the file name. This operation is possible only when a 
linked data file is displayed.

Procedure
1.	 Choose Save Display Setting As from the File menu.
2.	 The Select File dialog box opens. Specify the destination and file name and click 

OK.
	 The link file and display settings file are saved.

Note
When restoring links by loading a link file, the data files that are to be linked must reside in the 
same folder as the link file.
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Exiting Historical Viewer
If there are any unsaved display settings, a message appears prompting you to choose 
whether or not to save the settings. Make a selection as to whether or not to save the 
settings.

Procedure
1.	 Choose Exit from the File menu or click the X button at the right end of the title 

bar.

	 If there are unsaved display settings, a message appears prompting you to 
choose whether or not to save the settings.

					   

2.	 Click Yes, No, or Cancel.

	 Yes: Saves the display settings and closes Historical Viewer.

	 No: Does not save the display settings and closes Historical Viewer.

	 Cancel: Cancels the operation of exiting Historical Viewer.

5.11  Saving the Display Settings, Saving the Link Settings, and Exiting Historical Viewer
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6.1	 Error Messages and Corrective Actions

A message may appear on the screen during operation. This section describes the 
meanings of the messages and their corrective actions.

Code Message Corrective Action
E0002 Insufficient memory. Please exit at once. Exit all other programs and restart AddTrigger. Or, restart Widows.
E0003 Cannot open shared memory. Exit all other programs and restart AddTrigger. Or, restart Widows.
E0004 Invalid serial number. Reinstall AddTrigger.
E0101 Please open from the AddTrigger 

Launcher.
The program must be started from the Launcher.

E0213 Cannot open the file. Check whether the file exists, whether the file is of a type that 
the software supports, and whether the file system is operating 
normally.

E0211 Cannot write to the file. Check whether there is sufficient space on the hard disk, whether 
writing is permitted, and whether the file system is operating 
normally.

E4213 Failed to create folder. Up to 256 characters can be input for folder names.
E4601 Different server type. The port number that is displayed when you choose Port No. for 

Check the connected host name and port 
number.

Data Monitor from the File menu on the Launcher is already in use 
by another program.
Enter an unused port number.

E4602 The number of allowable client 
connections was exceeded.

The number of clients that are connected to the monitor server of 
the destination data logger software has been exceeded.  
Disconnect a client that is connected to the monitor server of the 
data logging software and connect AddTrigger.

E4603 A client with the same ID is connected 
from another PC.

A copy of AddTrigger with the same serial number is already 
connected to the monitor server of the data logging software. 
Reinstall the software using another serial number or disconnect 
the copy of AddTrigger that is currently connected.

E4605 Connection was dropped. Check whether the monitor server of the destination data logging 
software is running and whether the network is connected properly.

E4606 Could not initialize communications. Check whether TCP/IP is operating normally.
E4607 Connection failed. Check the connection 

host name and port number, and whether 
the monitor server is running.

Check whether the monitor server of the destination data logging 
software is running and whether the network is connected properly.

E4608 Time limit has passed. Check whether the monitor server of the data logging software is 
running and whether the network is connected properly.

E4609 Maximum packet size exceeded. The destination is not a monitor server that AddTrigger supports.  
Check whether the destination is a monitor server.

E4610 Invalid system number. System number not entered correctly. See the user’s manual for 
the connected data logging software.

E4611 Command not supported. The destination is not a monitor server that AddTrigger supports.
E4613 Could not create folder. Check whether the folder name is valid, write permissions were 

granted for the destination folder, sufficient disk space is available, 
and whether the file system is functioning properly.

E4614 Invalid folder name. Folder name that starts with a period is not allowed. Enter a correct 
folder name.

E4615 Connection to this monitor server is not 
allowed.

Check whether the destination is a monitor server that AddTrigger 
supports.

E4619 Password and confirmation mismatch. Enter the same characters for the password and password 
confirmation.

E4620 Invalid password. Enter the correct password.
E4621 Cannot exit while scanning or recording 

is in progress.
Stop scanning first, then exit the Launcher.

E4622 Cannot contain any of the following 
characters: 
\ / : , ; * ? " < > |

¢\ / : , ; * ? “ < >. Please reenter using allowable characters only.

E4624 Cannot exit AddTrigger while desktop 
protection is active.

Disable desktop protection first, then exit the Launcher.

E4625 Cannot exit AddTrigger while password 
protection is active.

Disable password protection first, then exit the Launcher.

Chapter 6	 Error Messages and Corrective Actions
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Code Message Corrective Action
E4626 Cannot shut down Windows while 

AddTrigger is running.
Shut down or log off after exiting Launcher.

E4627 A project with the same name already 
exists.

A name of a registered project cannot be used. Create a project 
with a different name.

E4633 Failed to start the logger. The program was not correctly installed, or copied files were
E4634 Failed to start the monitor server. corrupted or deleted during installation. Reinstall. You can uninstall.
E4635 Failed to start the file processor. the program without losing saved project information.
E4637 Failed to start Data Monitor.
E4638 Failed to start the data viewer.
E4640 Invalid project name. Project names that start with a period is not allowed. Enter a 

correct project name.
E4643 Could not create data file output folder. Check the settings for the folder specified for data file output.
E4653 No effective logging channels. Recording cannot be executed if channels are not assigned in the 

logging settings or if channels are assigned but valid channels do 
not exist. Assign a valid channel.

E4654 Recording was stopped since a monitor 
server setting may have been changed.

A setting was changed on the destination data logging. To restart 
recording, carry out the start recording procedure again on the 
Launcher.

E4656 Failed to open the data file. Check whether the destination folder exists, write permissions were 
granted for the destination folder, sufficient disk space is available, 
and whether the file system is operating properly.

E4657 Failed to write to the data file. Check whether the folder name is valid, write permissions were 
granted for the destination folder, sufficient disk space is available, 
and whether the file system is operating properly.

E4658 Invalid setting. The setting file was not created by AddTrigger, or it was created by 
a different version of AddTrigger. Install the most recent version of 
AddTrigger.

E4659 Monitor server has no data. Start data logging on the destination data logging software.
E4660 The monitor server is busy. Start sending data on the monitor server in the data logging 

software, then log data using AddTrigger.
E4661 Monitor server stopped data logging. Data logging on the destination data logging software was stopped, 

or data distribution stopped. To restart, start data logging on the 
data logging software, or start data distribution. Then, start logging 
using AddTrigger.

E4662 No effective recording channels. Recording/scanning cannot be executed if channels are not 
assigned in the logging settings or if channels are assigned but 
valid channels do not exist. Check the logging settings, and assign 
valid recording channels.

E4663 Failed to reconnect the monitor server. Couldn’t reconnect during a given time (120 seconds) after the 
connection is dropped. Check whether the monitor server of 
the data logging software is running and whether the network is 
connected properly.

E4664 Port number for Data Monitor is already 
in use.

The port number that is displayed when you choose Port No. for 
Data Monitor from the File menu on the Launcher is already in use 
by another program. Enter an unused port number.

E4665 The new port number for Data Monitor 
will be effective after restarting the server. 

To make the new port number for Data Monitor effective, restart the 
Launcher.

E4668 Failed to convert the data files. Failed to automatically convert the file. Check whether the 
destination folder exists, write permissions were granted for the 
destination folder, sufficient disk space is available, and whether 
the file system is operating properly.

E4669 Could not create conversion file output 
folder.

Check the settings for the folder specified for conversion file output.

E4683 Connection failed. Check whether the monitor server of the destination data logging 
software is running and whether the network is connected properly.

6.1  Error Messages and Corrective Actions
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